summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-10-21 17:27:29 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-22 08:47:07 +0700
commit34228eac647b49bbfd78b17b4f62185a1f2c4caa (patch)
tree62df6fe52dd0f78f9ea1f20db8b422961d172afd
parent1d0e23ee6ee602a73891fce27782618a4007423c (diff)
downloadslackbuilds-34228eac647b49bbfd78b17b4f62185a1f2c4caa.tar.gz
slackbuilds-34228eac647b49bbfd78b17b4f62185a1f2c4caa.tar.xz
python/threadpool: Updated for version 1.3.2.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--python/threadpool/threadpool.SlackBuild16
-rw-r--r--python/threadpool/threadpool.info6
2 files changed, 11 insertions, 11 deletions
diff --git a/python/threadpool/threadpool.SlackBuild b/python/threadpool/threadpool.SlackBuild
index 7c342a28be..b83c13e8d9 100644
--- a/python/threadpool/threadpool.SlackBuild
+++ b/python/threadpool/threadpool.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for threadpool
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=threadpool
-VERSION=${VERSION:-1.2.7}
+VERSION=${VERSION:-1.3.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -65,9 +65,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -75,7 +75,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.txt PKG-INFO CHANGELOG.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst PKG-INFO CHANGELOG.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/threadpool/threadpool.info b/python/threadpool/threadpool.info
index df62cfe855..cdf6a3be66 100644
--- a/python/threadpool/threadpool.info
+++ b/python/threadpool/threadpool.info
@@ -1,8 +1,8 @@
PRGNAM="threadpool"
-VERSION="1.2.7"
+VERSION="1.3.2"
HOMEPAGE="http://chrisarndt.de/projects/threadpool/"
-DOWNLOAD="http://chrisarndt.de/projects/threadpool/download/threadpool-1.2.7.tar.bz2"
-MD5SUM="e1d5a4f73440ed701dfd0b3eb0d9c1ca"
+DOWNLOAD="https://pypi.python.org/packages/1f/0f/e14266504330f08e8cddfe1bc03198a94193770c6740a4836985e8a64b5f/threadpool-1.3.2.tar.bz2"
+MD5SUM="343bd94fa32effcc9367d382323b4cb3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""