summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Hunter Sezen <ovariegata@yahoo.com>2016-07-27 19:50:33 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-07-30 08:28:43 +0700
commit3869dcac6e06e4dd9352911aae0c8db4cb4c3334 (patch)
treea884411b41f87d7eb789b3ecf3712586006aa8e4
parent38e40b752794a6669d73f780663a021456600a6c (diff)
downloadslackbuilds-3869dcac6e06e4dd9352911aae0c8db4cb4c3334.tar.gz
slackbuilds-3869dcac6e06e4dd9352911aae0c8db4cb4c3334.tar.xz
python/pyxdg: New maintainer; add python3 support
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--python/pyxdg/README4
-rw-r--r--python/pyxdg/pyxdg.SlackBuild26
-rw-r--r--python/pyxdg/pyxdg.info4
-rw-r--r--python/pyxdg/slack-desc2
4 files changed, 9 insertions, 27 deletions
diff --git a/python/pyxdg/README b/python/pyxdg/README
index 6247c59ae0..b42e24ed4f 100644
--- a/python/pyxdg/README
+++ b/python/pyxdg/README
@@ -1,5 +1,3 @@
PyXDG contains implementations of freedesktop.org standards in python.
-To install python3 bindings run the slackbuild with PYTHON3=yes.
-
- # PYTHON3=yes ./pyxdg.SlackBuild
+Python3 is an optional dependency.
diff --git a/python/pyxdg/pyxdg.SlackBuild b/python/pyxdg/pyxdg.SlackBuild
index f54fe8a8fd..79c3d19645 100644
--- a/python/pyxdg/pyxdg.SlackBuild
+++ b/python/pyxdg/pyxdg.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for PyXDG
# Copyright 2008-2009 Frank Caraballo <fecaraballo{at}gmail{dot}com>
+# Copyright 2016 Hunter Sezen California, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,12 +25,12 @@
PRGNAM=pyxdg
VERSION=${VERSION:-0.25}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,20 +41,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -71,14 +58,11 @@ find -L . \
python setup.py install --root $PKG
-# Install python3 bindings for pyxdg. Default is no.
-if [ "${PYTHON3:-no}" == "yes" ]; then
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS ChangeLog COPYING INSTALL PKG-INFO README TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/pyxdg/pyxdg.info b/python/pyxdg/pyxdg.info
index d8b9d32a7f..3fd0aa82dd 100644
--- a/python/pyxdg/pyxdg.info
+++ b/python/pyxdg/pyxdg.info
@@ -6,5 +6,5 @@ MD5SUM="bedcdb3a0ed85986d40044c87f23477c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Frank Caraballo"
-EMAIL="fecaraballo{at}gmail{dot}com"
+MAINTAINER="Hunter Sezen"
+EMAIL="ovariegata@yahoo.com"
diff --git a/python/pyxdg/slack-desc b/python/pyxdg/slack-desc
index 15d7742b14..eff528ea45 100644
--- a/python/pyxdg/slack-desc
+++ b/python/pyxdg/slack-desc
@@ -6,7 +6,7 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-pyxdg: PyXDG (Python Library)
+pyxdg: PyXDG (Python XDG Library)
pyxdg:
pyxdg: PyXDG contains implementations of freedesktop.org standards in python.
pyxdg: