summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Hunter Sezen <ovariegata@yahoo.com>2016-07-27 19:48:30 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-07-30 08:28:43 +0700
commit38e40b752794a6669d73f780663a021456600a6c (patch)
tree911faeb057b3488854acc6673f3ecd620bfbcdc6
parenta6f39ea22578e05d4120650e3b0e8d88ef4df7ff (diff)
downloadslackbuilds-38e40b752794a6669d73f780663a021456600a6c.tar.gz
slackbuilds-38e40b752794a6669d73f780663a021456600a6c.tar.xz
python/setuptools-scm: Added (manage versions by scm tags)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--python/setuptools-scm/README6
-rw-r--r--python/setuptools-scm/setuptools-scm.SlackBuild74
-rw-r--r--python/setuptools-scm/setuptools-scm.info10
-rw-r--r--python/setuptools-scm/slack-desc19
4 files changed, 109 insertions, 0 deletions
diff --git a/python/setuptools-scm/README b/python/setuptools-scm/README
new file mode 100644
index 0000000000..98578d9dd2
--- /dev/null
+++ b/python/setuptools-scm/README
@@ -0,0 +1,6 @@
+setuptools_scm handles managing your python package versions in scm metadata instead
+of declaring them as the version argument or in a scm managed file.
+
+It also handles file finders for the supported scm's.
+
+Python3 is an optional dependency.
diff --git a/python/setuptools-scm/setuptools-scm.SlackBuild b/python/setuptools-scm/setuptools-scm.SlackBuild
new file mode 100644
index 0000000000..5b1984f6ec
--- /dev/null
+++ b/python/setuptools-scm/setuptools-scm.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/sh
+
+# Slackware build script for setuptools-scm
+
+# Copyright 2016 Hunter Sezen California, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=setuptools-scm
+SRCNAM=$(echo $PRGNAM | tr - _)
+VERSION=${VERSION:-1.11.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.rst LICENSE PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/setuptools-scm/setuptools-scm.info b/python/setuptools-scm/setuptools-scm.info
new file mode 100644
index 0000000000..e607e96f4d
--- /dev/null
+++ b/python/setuptools-scm/setuptools-scm.info
@@ -0,0 +1,10 @@
+PRGNAM="setuptools-scm"
+VERSION="1.11.1"
+HOMEPAGE="https://github.com/pypa/setuptools_scm/"
+DOWNLOAD="https://pypi.python.org/packages/84/aa/c693b5d41da513fed3f0ee27f1bf02a303caa75bbdfa5c8cc233a1d778c4/setuptools_scm-1.11.1.tar.gz"
+MD5SUM="4d19b2bc9580016d991f665ac20e2e8f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Hunter Sezen"
+EMAIL="ovariegata@yahoo.com"
diff --git a/python/setuptools-scm/slack-desc b/python/setuptools-scm/slack-desc
new file mode 100644
index 0000000000..02fa8597c2
--- /dev/null
+++ b/python/setuptools-scm/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+setuptools-scm: setuptools-scm (manage versions by scm tags)
+setuptools-scm:
+setuptools-scm: setuptools_scm handles managing your python package versions in scm
+setuptools-scm: metadata instead of declaring them as the version argument or in a
+setuptools-scm: scm managed file.
+setuptools-scm:
+setuptools-scm: It also handles file finders for the supported scm’s.
+setuptools-scm:
+setuptools-scm: Homepage: https://github.com/pypa/setuptools_scm/
+setuptools-scm:
+setuptools-scm: