summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-10-20 20:09:14 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-20 20:09:14 +0700
commit42ac4dbd67fe34ef18fdcc67a1bc3ff07e39d728 (patch)
treea61a478ec30af8047db2e3ad249d50090cacc8a6
parentc8b4eba3a145fe69be8f2820b2052a15adbdabe1 (diff)
downloadslackbuilds-42ac4dbd67fe34ef18fdcc67a1bc3ff07e39d728.tar.gz
slackbuilds-42ac4dbd67fe34ef18fdcc67a1bc3ff07e39d728.tar.xz
libraries/smmap2: Added (A sliding memory map manager).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/smmap2/README4
-rw-r--r--libraries/smmap2/slack-desc19
-rw-r--r--libraries/smmap2/smmap2.SlackBuild85
-rw-r--r--libraries/smmap2/smmap2.info10
4 files changed, 118 insertions, 0 deletions
diff --git a/libraries/smmap2/README b/libraries/smmap2/README
new file mode 100644
index 0000000000..24a6bb75d7
--- /dev/null
+++ b/libraries/smmap2/README
@@ -0,0 +1,4 @@
+Smmap wraps an interface around mmap and tracks the mapped files
+as well as the amount of clients who use it. If the system runs
+out of resources, or if a memory limit is reached, it will
+automatically unload unused maps to allow continued operation.
diff --git a/libraries/smmap2/slack-desc b/libraries/smmap2/slack-desc
new file mode 100644
index 0000000000..bed50ef772
--- /dev/null
+++ b/libraries/smmap2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+smmap2: smmap2 (A sliding memory map manager)
+smmap2:
+smmap2: Smmap wraps an interface around mmap and tracks the mapped files as
+smmap2: well as the amount of clients who use it. If the system runs out of
+smmap2: resources, or if a memory limit is reached, it will automatically
+smmap2: unload unused maps to allow continued operation.
+smmap2:
+smmap2: Homepage: https://github.com/gitpython-developers/smmap
+smmap2:
+smmap2:
+smmap2:
diff --git a/libraries/smmap2/smmap2.SlackBuild b/libraries/smmap2/smmap2.SlackBuild
new file mode 100644
index 0000000000..84d152b661
--- /dev/null
+++ b/libraries/smmap2/smmap2.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for smmap2
+
+# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=smmap2
+VERSION=${VERSION:-2.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/smmap2/smmap2.info b/libraries/smmap2/smmap2.info
new file mode 100644
index 0000000000..62f46d8299
--- /dev/null
+++ b/libraries/smmap2/smmap2.info
@@ -0,0 +1,10 @@
+PRGNAM="smmap2"
+VERSION="2.0.0"
+HOMEPAGE="https://github.com/gitpython-developers/smmap"
+DOWNLOAD="https://pypi.python.org/packages/5b/d5/97faff73464a3185c99c6a530c3ae349461048bc3cb9f847a2aedd1d488a/smmap2-2.0.0.tar.gz"
+MD5SUM="efe9be52b0668995a9915de043d517a2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"