summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2016-07-22 02:00:01 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-07-24 07:27:53 +0700
commit9aeb08acd1de0fd7ac1745d0671ed8ade57f9d1a (patch)
tree3c30bb50d54a0abf5a321dc4f0d55021653f8499
parente4f1b8a198ef6036031bc54ff80c0376410c1ec1 (diff)
downloadslackbuilds-9aeb08acd1de0fd7ac1745d0671ed8ade57f9d1a.tar.gz
slackbuilds-9aeb08acd1de0fd7ac1745d0671ed8ade57f9d1a.tar.xz
python/pyusb: Updated for version 1.0.0.
Signed-off-by: Kyle Guinn <elyk03@gmail.com>
-rw-r--r--python/pyusb/README5
-rw-r--r--python/pyusb/pyusb.SlackBuild23
-rw-r--r--python/pyusb/pyusb.info6
-rw-r--r--python/pyusb/slack-desc6
4 files changed, 11 insertions, 29 deletions
diff --git a/python/pyusb/README b/python/pyusb/README
index c93b48b72b..9c8a61e6b1 100644
--- a/python/pyusb/README
+++ b/python/pyusb/README
@@ -1,3 +1,2 @@
-PyUSB is a native Python module written in C which provides easy USB access
-to Python. The module contains classes and methods to support most USB
-operations.
+PyUSB is a native Python module which provides easy USB access to Python.
+The module contains classes and methods to support most USB operations.
diff --git a/python/pyusb/pyusb.SlackBuild b/python/pyusb/pyusb.SlackBuild
index 93dfe807cc..c84f256558 100644
--- a/python/pyusb/pyusb.SlackBuild
+++ b/python/pyusb/pyusb.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for PyUSB
-# Copyright 2014 Kyle Guinn <elyk03@gmail.com>, USA
+# Copyright 2014-2016 Kyle Guinn <elyk03@gmail.com>, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyusb
-VERSION=${VERSION:-0.4.3}
+VERSION=${VERSION:-1.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -40,17 +40,7 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM-$VERSION
OUTPUT=${OUTPUT:-/tmp}
-DOCS="LICENSE README"
-
-if [ $ARCH = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ $ARCH = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ $ARCH = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-else
- SLKCFLAGS="-O2"
-fi
+DOCS="ACKNOWLEDGEMENTS ChangeLog LICENSE README.rst docs/faq.rst docs/tutorial.rst"
set -e
@@ -63,15 +53,8 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .
-CFLAGS="$SLKCFLAGS" \
python ./setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Normalize line endings
-sed -i "s/\xd$//g" README
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/pyusb/pyusb.info b/python/pyusb/pyusb.info
index 873865101c..9027c157a9 100644
--- a/python/pyusb/pyusb.info
+++ b/python/pyusb/pyusb.info
@@ -1,8 +1,8 @@
PRGNAM="pyusb"
-VERSION="0.4.3"
+VERSION="1.0.0"
HOMEPAGE="https://walac.github.io/pyusb/"
-DOWNLOAD="http://downloads.sourceforge.net/pyusb/pyusb-0.4.3.tar.gz"
-MD5SUM="a1a43bc6407caccbc22073c56439aa06"
+DOWNLOAD="http://downloads.sourceforge.net/pyusb/pyusb-1.0.0.tar.gz"
+MD5SUM="9b173ae33866a2fb4162e0164f01c284"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/python/pyusb/slack-desc b/python/pyusb/slack-desc
index aa1e9fe701..36a0f7468b 100644
--- a/python/pyusb/slack-desc
+++ b/python/pyusb/slack-desc
@@ -8,9 +8,9 @@
|-----handy-ruler------------------------------------------------------|
pyusb: PyUSB (USB module for Python)
pyusb:
-pyusb: PyUSB is a native Python module written in C which provides easy USB
-pyusb: access to Python. The module contains classes and methods to
-pyusb: support most USB operations.
+pyusb: PyUSB is a native Python module which provides easy USB access to
+pyusb: Python. The module contains classes and methods to support most USB
+pyusb: operations.
pyusb:
pyusb:
pyusb: