summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Petr Kletecka <petr@kle.cz>2013-06-04 17:15:43 -0400
committer Robby Workman <rworkman@slackbuilds.org>2013-06-05 03:17:45 -0500
commitd7894f52fcd9dd64ecdc892ac4cbb274eaef0ce0 (patch)
tree944e349dda84d5e1ffe2bca2ccf038039f92c4b6
parentded40d930b96b42bcf9dd589ddf66358f82ce79f (diff)
downloadslackbuilds-d7894f52fcd9dd64ecdc892ac4cbb274eaef0ce0.tar.gz
slackbuilds-d7894f52fcd9dd64ecdc892ac4cbb274eaef0ce0.tar.xz
system/dtrx: Added (Intelligent archive extraction)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--system/dtrx/README12
-rw-r--r--system/dtrx/dtrx.SlackBuild46
-rw-r--r--system/dtrx/dtrx.info10
-rw-r--r--system/dtrx/slack-desc19
4 files changed, 87 insertions, 0 deletions
diff --git a/system/dtrx/README b/system/dtrx/README
new file mode 100644
index 0000000000..c2aa0c3879
--- /dev/null
+++ b/system/dtrx/README
@@ -0,0 +1,12 @@
+dtrx extracts archives in a number of different
+formats; it currently supports tar, zip (including self-extracting
+.exe files), cpio, rpm, deb, gem, 7z, cab, rar, and InstallShield
+files. It can also decompress files compressed with gzip, bzip2,
+lzma, xz, or compress.
+
+In addition to providing one command to handle many different archive
+types, dtrx also aids the user by extracting contents consistently.
+By default, everything will be written to a dedicated directory
+that's named after the archive. dtrx will also change the
+permissions to ensure that the owner can read and write all those
+files.
diff --git a/system/dtrx/dtrx.SlackBuild b/system/dtrx/dtrx.SlackBuild
new file mode 100644
index 0000000000..bde452986c
--- /dev/null
+++ b/system/dtrx/dtrx.SlackBuild
@@ -0,0 +1,46 @@
+#!/bin/sh
+
+# Slackware build script for dtrx
+
+# Petr Kletecka petr@kle.cz <2013>
+
+PRGNAM=dtrx
+VERSION=${VERSION:-7.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+ARCH=noarch
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xf $CWD/${PRGNAM}-${VERSION}.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --prefix $PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ NEWS README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/dtrx/dtrx.info b/system/dtrx/dtrx.info
new file mode 100644
index 0000000000..c3006304f6
--- /dev/null
+++ b/system/dtrx/dtrx.info
@@ -0,0 +1,10 @@
+PRGNAM="dtrx"
+VERSION="7.1"
+HOMEPAGE="http://brettcsmith.org/2007/dtrx/"
+DOWNLOAD="http://brettcsmith.org/2007/dtrx/dtrx-7.1.tar.gz"
+MD5SUM="4be207724b75aea3e9f93374298b2174"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Petr Kletecka"
+EMAIL="petr@kle.cz"
diff --git a/system/dtrx/slack-desc b/system/dtrx/slack-desc
new file mode 100644
index 0000000000..a2e190b8f2
--- /dev/null
+++ b/system/dtrx/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+dtrx: dtrx (Intelligent archive extraction)
+dtrx:
+dtrx: dtrx extracts archives in a number of different formats.
+dtrx: In addition to providing one command to handle many different archive
+dtrx: types, dtrx also aids the user by extracting contents consistently.
+dtrx: By default, everything will be written to a dedicated directory
+dtrx: that's named after the archive. dtrx will also change the
+dtrx: permissions to ensure that the owner can read and write all those
+dtrx: files.
+dtrx:
+dtrx: website: http://brettcsmith.org/2007/dtrx/