summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2016-08-26 08:44:36 -0700
committer David Spencer <idlemoor@slackbuilds.org>2016-08-28 00:26:21 +0100
commitf2407780466b3ccb48a88b9ec2e2308f24d843cf (patch)
treee595959934335bbfcc4ed88b4e4718155513b971
parentfec0275bf29d03432a6fea7606a78c13003ecb51 (diff)
downloadslackbuilds-f2407780466b3ccb48a88b9ec2e2308f24d843cf.tar.gz
slackbuilds-f2407780466b3ccb48a88b9ec2e2308f24d843cf.tar.xz
python/netifaces: Updated for version 0.10.5
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
-rw-r--r--python/netifaces/README2
-rw-r--r--python/netifaces/netifaces.SlackBuild18
-rw-r--r--python/netifaces/netifaces.info6
3 files changed, 10 insertions, 16 deletions
diff --git a/python/netifaces/README b/python/netifaces/README
index 4c622be1e5..008cffeaeb 100644
--- a/python/netifaces/README
+++ b/python/netifaces/README
@@ -1,3 +1 @@
Portable module to access network interface information in Python.
-
-python3 is an optional dependency.
diff --git a/python/netifaces/netifaces.SlackBuild b/python/netifaces/netifaces.SlackBuild
index d2641cc9ac..60acb41e48 100644
--- a/python/netifaces/netifaces.SlackBuild
+++ b/python/netifaces/netifaces.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for netifaces
-# Copyright 2012-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=netifaces
-VERSION=${VERSION:-0.10.4}
+VERSION=${VERSION:-0.10.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -50,17 +50,13 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-if $(python3 -c 'import setuptools' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/netifaces/netifaces.info b/python/netifaces/netifaces.info
index 6fa55b5f69..b0081070c8 100644
--- a/python/netifaces/netifaces.info
+++ b/python/netifaces/netifaces.info
@@ -1,8 +1,8 @@
PRGNAM="netifaces"
-VERSION="0.10.4"
+VERSION="0.10.5"
HOMEPAGE="http://alastairs-place.net/projects/netifaces/"
-DOWNLOAD="https://pypi.python.org/packages/source/n/netifaces/netifaces-0.10.4.tar.gz"
-MD5SUM="36da76e2cfadd24cc7510c2c0012eb1e"
+DOWNLOAD="https://pypi.io/packages/source/n/netifaces/netifaces-0.10.5.tar.gz"
+MD5SUM="5b4d1f1310ed279e6df27ef3a9b71519"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""