summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-10-21 17:35:16 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-22 08:47:07 +0700
commitf32f4e25e33ecad953c0135b017c0b64e288c74d (patch)
treea8f66d1cdc40ee1b26e1fbf8fe0558e2d3487f5e
parent34228eac647b49bbfd78b17b4f62185a1f2c4caa (diff)
downloadslackbuilds-f32f4e25e33ecad953c0135b017c0b64e288c74d.tar.gz
slackbuilds-f32f4e25e33ecad953c0135b017c0b64e288c74d.tar.xz
python/helpy: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--python/helpy/helpy.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/python/helpy/helpy.SlackBuild b/python/helpy/helpy.SlackBuild
index 606c270508..59da59793c 100644
--- a/python/helpy/helpy.SlackBuild
+++ b/python/helpy/helpy.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for helpy
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG