summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2016-08-25 19:55:03 -0700
committer David Spencer <idlemoor@slackbuilds.org>2016-08-28 00:26:21 +0100
commitfec0275bf29d03432a6fea7606a78c13003ecb51 (patch)
tree184a898a5e7a44e6c4d5bc391edf4522f3f81198
parent36a751865505579841766c1c91a8c5c463a44422 (diff)
downloadslackbuilds-fec0275bf29d03432a6fea7606a78c13003ecb51.tar.gz
slackbuilds-fec0275bf29d03432a6fea7606a78c13003ecb51.tar.xz
multimedia/kodi: Updated for version 16.1
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
-rw-r--r--multimedia/kodi/README5
-rw-r--r--multimedia/kodi/kodi.SlackBuild53
-rw-r--r--multimedia/kodi/kodi.info12
3 files changed, 23 insertions, 47 deletions
diff --git a/multimedia/kodi/README b/multimedia/kodi/README
index c97c46176a..03e3958067 100644
--- a/multimedia/kodi/README
+++ b/multimedia/kodi/README
@@ -5,9 +5,8 @@ viewing and playing a vast library of audio, video and image formats.
Kodi has a sophisticated library management system that allows you to
organize all your media to give you quick and immediate access.
-Optional dependencies: libcec, libbluray, libnfs, libva, libdvdcss,
-lirc, cwiid, pybluez, id3lib, libvdpau, rtmpdump, afpfs-ng, avahi,
-lame, SDL2, libmodplug and openjdk
+Optional dependencies: libcec, libbluray, libnfs, lirc, cwiid, pybluez,
+rtmpdump, avahi, SDL2 and openjdk
Optional: libcrystalhd and libshairport (not available at slackbuilds.org)
diff --git a/multimedia/kodi/kodi.SlackBuild b/multimedia/kodi/kodi.SlackBuild
index 60b8cd3fa3..4f0d65e10e 100644
--- a/multimedia/kodi/kodi.SlackBuild
+++ b/multimedia/kodi/kodi.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for kodi
-# Copyright 2009-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,15 +24,15 @@
PRGNAM=kodi
SRCNAM=xbmc
-CODNAM=Isengard
-VERSION=${VERSION:-15.2}
-FFMPEGVER=${FFMPEGVER:-2.6.4}
+CODNAM=Jarvis
+VERSION=${VERSION:-16.1}
+FFMPEGVER=${FFMPEGVER:-2.8.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -43,8 +43,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=native -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -63,18 +63,10 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION-$CODNAM
-tar xvf $CWD/$SRCNAM-$VERSION-$CODNAM.tar.gz 2>/dev/null || tar xvf $CWD/$VERSION-$CODNAM.tar.gz
+tar xvf $CWD/$SRCNAM-$VERSION-$CODNAM.tar.gz
cd $SRCNAM-$VERSION-$CODNAM
# Don't have the Makefile download ffmpeg during install.
-if [ -f "$CWD/FFmpeg-${FFMPEGVER}-${CODNAM}.tar.gz" ]; then
- ln -s $CWD/FFmpeg-${FFMPEGVER}-${CODNAM}.tar.gz tools/depends/target/ffmpeg/ffmpeg-${FFMPEGVER}-${CODNAM}.tar.gz
-elif [ -f "$CWD/${FFMPEGVER}-${CODNAM}.tar.gz" ]; then
- ln -s $CWD/${FFMPEGVER}-${CODNAM}.tar.gz tools/depends/target/ffmpeg/ffmpeg-${FFMPEGVER}-${CODNAM}.tar.gz
-else
- echo "FFMPEG wasn't found. Please download it and have it available"
- echo "in the source directory ${CWD}."
- exit 1
-fi
+ln -s $CWD/FFmpeg-${FFMPEGVER}-${CODNAM}-16.0.tar.gz tools/depends/target/ffmpeg/ffmpeg-${FFMPEGVER}-${CODNAM}-16.0.tar.gz
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -83,7 +75,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# No need to show Git: "Version" in a release build.
-sed -i '/Git:/s|.*| return GetVersionShort();|' $SRCNAM/GUIInfoManager.cpp
+sed -i '/Git:/s|.*| return GetVersionShort();|' $SRCNAM/utils/SystemInfo.cpp
# Patch for building against rtmpdump. Only needed if xbmc fails to build
# w/rtmpdump. See the following link for a rather obtuse explanation.
@@ -100,15 +92,6 @@ patch -p1 < $CWD/patches/xbmc-15.0-dvdread.patch
# Issue: http://forum.kodi.tv/showthread.php?tid=220407
patch -p0 < $CWD/patches/kodi-texturepacker.patch
-# Hack for using afpfs-ng.
-cat lib/afpfs-ng/fix_afpfs-ng_includes.patch | head -1336 | tail -1172 | patch -p1
-AFPFS_NGFLAGS="-I$PWD/include"
-
-# Fix build failure with new g++ or libstdc++ or whatever
-sed -i \
- -e 's/#define projectM_isnan isnan/#define projectM_isnan std::isnan/' \
- xbmc/visualizations/XBMCProjectM/libprojectM/Common.hpp
-
# The version of ffmpeg on SBo is too old to compile kodi.
# Optional ffmpeg is still available but not turned on by
# default.
@@ -127,25 +110,19 @@ fi
export PATH="$PATH:$PWD/tools/depends/native/JsonSchemaBuilder/bin"
-# Need to fix an autoreconf error with older version of pkg-config.
-# http://forum.kodi.tv/showthread.php?tid=195791
-cat /usr/share/aclocal/pkg.m4 > m4/pkg.m4
-echo 'm4_pattern_allow([^PKG_CONFIG(_(PATH|LIBDIR|SYSROOT_DIR|ALLOW_SYSTEM_(CFLAGS|LIBS)))?$])' \
- >> m4/pkg.m4
-sed -i "/autoreconf/s|.*|& -I $PWD/m4|" bootstrap.mk
./bootstrap
-CFLAGS="$SLKCFLAGS $AFPFS_NGFLAGS" \
-CXXFLAGS="$SLKCFLAGS $AFPFS_NGFLAGS" \
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--docdir=/usr/doc/$PRGNAM-$VERSION \
+ --disable-silent-rules \
--enable-static=no \
--disable-debug \
--enable-gl \
--enable-mid \
- --enable-goom \
--enable-alsa \
--disable-asap-codec \
--enable-texturepacker \
@@ -160,7 +137,7 @@ if ! [ "${WII:-no}" = "no" ]; then
make eventclients DESTDIR=$PKG WII_EXTRA_OPTS="-DCWIID_OLD"
find $PKG/usr/lib${LIBDIRSUFFIX}/python* -iname "*\.py" -exec chmod 0644 '{}' \;
# Create byte-compiled python files.
- python -m compileall $PKG/usr/lib${LIBDIRSUFFIX}/python*/site-packages/$PRGNAM
+ python -m compileall $PKG/usr/lib${LIBDIRSUFFIX}/python*/site-packages/$PRGNAM 2>/dev/null
fi
make install DESTDIR=$PKG
@@ -178,7 +155,7 @@ for i in $PRGNAM.bin.1 $PRGNAM.1 $PRGNAM-standalone.1; do
done
if ! [ "${WII:-no}" = "no" ]; then
- for i in $PRGNAM-j2meremote.1 $PRGNAM-ps3remote.1 $PRGNAM-wiiremote.1 $PRGNAM-send.1; do
+ for i in $PRGNAM-j2meremote.1 $PRGNAM-ps3remote.1 $PRGNAM-send.1 $PRGNAM-wiiremote.1; do
install -m 0644 docs/manpages/$i $PKG/usr/man/man1/$i
done
fi
diff --git a/multimedia/kodi/kodi.info b/multimedia/kodi/kodi.info
index 59bad42bd9..74c8158ded 100644
--- a/multimedia/kodi/kodi.info
+++ b/multimedia/kodi/kodi.info
@@ -1,12 +1,12 @@
PRGNAM="kodi"
-VERSION="15.2"
+VERSION="16.1"
HOMEPAGE="https://kodi.tv/"
-DOWNLOAD="https://github.com/xbmc/xbmc/archive/15.2-Isengard.tar.gz \
- https://github.com/xbmc/FFmpeg/archive/2.6.4-Isengard.tar.gz"
-MD5SUM="c2fc432da92df09ca827d39e32167880 \
- 3dbd015fbfea2cbedf1fbd0779ab987e"
+DOWNLOAD="https://github.com/xbmc/xbmc/archive/16.1-Jarvis/xbmc-16.1-Jarvis.tar.gz \
+ https://github.com/xbmc/FFmpeg/archive/2.8.6-Jarvis-16.0/FFmpeg-2.8.6-Jarvis-16.0.tar.gz"
+MD5SUM="79358ad5f77f42c5498a9412d5a78dd5 \
+ 91292b7dc99b9d055e4ad7b9644c9738"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="jdk libass libmpeg2 yajl tinyxml libmicrohttpd"
+REQUIRES="jdk libass libmpeg2 dcadec crossguid yajl tinyxml libmicrohttpd"
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"