summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2016-10-05 09:08:58 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-08 08:07:33 +0700
commit9a58f6a5927aff069c1d1aae16ecf109757234cb (patch)
treed447fbc547e6e61eafc0c99c5cccd83d14117514 /academic
parentbe5b136d918ad5f0b2779d77f11f5a448eea6b10 (diff)
downloadslackbuilds-9a58f6a5927aff069c1d1aae16ecf109757234cb.tar.gz
slackbuilds-9a58f6a5927aff069c1d1aae16ecf109757234cb.tar.xz
academic/cblas: Updated for version 3.6.1.
Signed-off-by: Kyle Guinn <elyk03@gmail.com>
Diffstat (limited to 'academic')
-rw-r--r--academic/cblas/cblas.SlackBuild6
-rw-r--r--academic/cblas/cblas.info6
-rw-r--r--academic/cblas/patches/cmake-piecewise.diff12
-rw-r--r--academic/cblas/patches/generate-pkgconfig.diff26
-rw-r--r--academic/cblas/patches/link-dependencies.diff8
-rw-r--r--academic/cblas/patches/target-cleanup.diff33
6 files changed, 44 insertions, 47 deletions
diff --git a/academic/cblas/cblas.SlackBuild b/academic/cblas/cblas.SlackBuild
index 2aa85d604b..4dbd11b04b 100644
--- a/academic/cblas/cblas.SlackBuild
+++ b/academic/cblas/cblas.SlackBuild
@@ -24,13 +24,13 @@
PRGNAM=cblas
SRCNAM=lapack
-VERSION=${VERSION:-3.6.0}
+VERSION=${VERSION:-3.6.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$(uname -m) ;;
esac
@@ -45,6 +45,8 @@ DOCS="LICENSE CBLAS/README"
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
diff --git a/academic/cblas/cblas.info b/academic/cblas/cblas.info
index d6c4e18d3c..6b9fafd846 100644
--- a/academic/cblas/cblas.info
+++ b/academic/cblas/cblas.info
@@ -1,8 +1,8 @@
PRGNAM="cblas"
-VERSION="3.6.0"
+VERSION="3.6.1"
HOMEPAGE="http://www.netlib.org/blas/"
-DOWNLOAD="http://www.netlib.org/lapack/lapack-3.6.0.tgz"
-MD5SUM="f2f6c67134e851fe189bb3ca1fbb5101"
+DOWNLOAD="http://www.netlib.org/lapack/lapack-3.6.1.tgz"
+MD5SUM="421b2cb72e15f237e144428f9c460ee0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="blas"
diff --git a/academic/cblas/patches/cmake-piecewise.diff b/academic/cblas/patches/cmake-piecewise.diff
index 13402a52e7..1dc85494a7 100644
--- a/academic/cblas/patches/cmake-piecewise.diff
+++ b/academic/cblas/patches/cmake-piecewise.diff
@@ -160,7 +160,7 @@ deleted file mode 100644
diff --git a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -55,8 +55,6 @@
+@@ -81,8 +81,6 @@
endif()
# --------------------------------------------------
@@ -169,7 +169,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
if (UNIX)
include(GNUInstallDirs)
set(ARCHIVE_DIR ${CMAKE_INSTALL_LIBDIR})
-@@ -70,7 +68,6 @@
+@@ -96,7 +94,6 @@
macro(lapack_install_library lib)
install(TARGETS ${lib}
@@ -177,7 +177,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
ARCHIVE DESTINATION ${ARCHIVE_DIR}
LIBRARY DESTINATION ${LIBRARY_DIR}
RUNTIME DESTINATION ${RUNTIME_DIR}
-@@ -96,20 +93,6 @@
+@@ -122,20 +119,6 @@
include( CheckLAPACKCompilerFlags )
CheckLAPACKCompilerFlags()
@@ -198,7 +198,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
set(PKG_CONFIG_DIR ${LIBRARY_DIR}/pkgconfig)
set(prefix ${CMAKE_INSTALL_PREFIX})
-@@ -120,6 +103,11 @@
+@@ -146,6 +129,11 @@
endif()
# --------------------------------------------------
@@ -210,7 +210,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
# Precision to build
# By default all precisions are generated
option(BUILD_SINGLE "Build Single Precision" ON)
-@@ -150,236 +138,134 @@
+@@ -176,236 +164,134 @@
Please enable at least one of these: BUILD_SINGLE, BUILD_DOUBLE, BUILD_COMPLEX, BUILD_COMPLEX16.")
endif()
@@ -548,7 +548,7 @@ diff --git a/LAPACKE/CMakeLists.txt b/LAPACKE/CMakeLists.txt
-install(FILES
- ${CMAKE_CURRENT_BINARY_DIR}/CMakeFiles/lapacke-config.cmake
- ${LAPACK_BINARY_DIR}/lapacke-config-version.cmake
-- DESTINATION lib/cmake/lapacke-${LAPACK_VERSION}
+- DESTINATION ${LIBRARY_DIR}/cmake/lapacke-${LAPACK_VERSION}
- )
-
-install(EXPORT lapacke-targets
diff --git a/academic/cblas/patches/generate-pkgconfig.diff b/academic/cblas/patches/generate-pkgconfig.diff
index f481ab8085..b351f46d56 100644
--- a/academic/cblas/patches/generate-pkgconfig.diff
+++ b/academic/cblas/patches/generate-pkgconfig.diff
@@ -13,15 +13,20 @@ diff --git a/BLAS/CMakeLists.txt b/BLAS/CMakeLists.txt
diff --git a/BLAS/blas.pc.in b/BLAS/blas.pc.in
--- a/BLAS/blas.pc.in
+++ b/BLAS/blas.pc.in
-@@ -1,7 +1,7 @@
- prefix=@prefix@
- libdir=@libdir@
+@@ -1,9 +1,9 @@
+-prefix=@CMAKE_INSTALL_PREFIX@
+-libdir=@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_LIBDIR@
++prefix=@prefix@
++libdir=@libdir@
-Name: blas
+Name: BLAS
Description: Basic Linear Algebra Subprograms F77 reference implementations
Version: @LAPACK_VERSION@
URL: http://www.netlib.org/blas/
+-Libs: -L@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_LIBDIR@ -lblas
++Libs: -L${libdir} -lblas
+ Libs.private: -lm
diff --git a/CBLAS/CMakeLists.txt b/CBLAS/CMakeLists.txt
--- a/CBLAS/CMakeLists.txt
+++ b/CBLAS/CMakeLists.txt
@@ -53,7 +58,7 @@ diff --git a/CBLAS/cblas.pc.in b/CBLAS/cblas.pc.in
diff --git a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -112,6 +112,13 @@
+@@ -138,6 +138,13 @@
set(DSECOND_SRC ${LAPACK_SOURCE_DIR}/INSTALL/dsecnd_${TIME_FUNC}.f)
set(PKG_CONFIG_DIR ${LIBRARY_DIR}/pkgconfig)
@@ -67,7 +72,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
# --------------------------------------------------
# Precision to build
# By default all precisions are generated
-@@ -333,7 +340,7 @@
+@@ -359,7 +366,7 @@
${LAPACK_BINARY_DIR}/lapack-config.cmake @ONLY)
@@ -106,12 +111,17 @@ diff --git a/LAPACKE/lapacke.pc.in b/LAPACKE/lapacke.pc.in
diff --git a/lapack.pc.in b/lapack.pc.in
--- a/lapack.pc.in
+++ b/lapack.pc.in
-@@ -1,7 +1,7 @@
- prefix=@prefix@
- libdir=@libdir@
+@@ -1,9 +1,9 @@
+-prefix=@CMAKE_INSTALL_PREFIX@
+-libdir=@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_LIBDIR@
++prefix=@prefix@
++libdir=@libdir@
-Name: lapack
+Name: LAPACK
Description: FORTRAN reference implementation of LAPACK Linear Algebra PACKage
Version: @LAPACK_VERSION@
URL: http://www.netlib.org/lapack/
+-Libs: -L@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_LIBDIR@ -llapack
++Libs: -L${libdir} -llapack
+ Requires: blas
diff --git a/academic/cblas/patches/link-dependencies.diff b/academic/cblas/patches/link-dependencies.diff
index 31a2bcc642..c958ebb0cb 100644
--- a/academic/cblas/patches/link-dependencies.diff
+++ b/academic/cblas/patches/link-dependencies.diff
@@ -63,7 +63,7 @@ diff --git a/CBLAS/src/CMakeLists.txt b/CBLAS/src/CMakeLists.txt
diff --git a/CBLAS/testing/CMakeLists.txt b/CBLAS/testing/CMakeLists.txt
--- a/CBLAS/testing/CMakeLists.txt
+++ b/CBLAS/testing/CMakeLists.txt
-@@ -55,9 +55,9 @@
+@@ -54,9 +54,9 @@
add_executable(xscblat2 c_sblat2.f ${STESTL2O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
add_executable(xscblat3 c_sblat3.f ${STESTL3O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
@@ -76,7 +76,7 @@ diff --git a/CBLAS/testing/CMakeLists.txt b/CBLAS/testing/CMakeLists.txt
add_cblas_test(stest1.out "" xscblat1)
add_cblas_test(stest2.out sin2 xscblat2)
-@@ -71,9 +71,9 @@
+@@ -70,9 +70,9 @@
add_executable(xdcblat2 c_dblat2.f ${DTESTL2O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
add_executable(xdcblat3 c_dblat3.f ${DTESTL3O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
@@ -89,7 +89,7 @@ diff --git a/CBLAS/testing/CMakeLists.txt b/CBLAS/testing/CMakeLists.txt
add_cblas_test(dtest1.out "" xdcblat1)
add_cblas_test(dtest2.out din2 xdcblat2)
-@@ -87,9 +87,9 @@
+@@ -86,9 +86,9 @@
add_executable(xccblat2 c_cblat2.f ${CTESTL2O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
add_executable(xccblat3 c_cblat3.f ${CTESTL3O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
@@ -102,7 +102,7 @@ diff --git a/CBLAS/testing/CMakeLists.txt b/CBLAS/testing/CMakeLists.txt
add_cblas_test(ctest1.out "" xccblat1)
add_cblas_test(ctest2.out cin2 xccblat2)
-@@ -103,9 +103,9 @@
+@@ -102,9 +102,9 @@
add_executable(xzcblat2 c_zblat2.f ${ZTESTL2O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
add_executable(xzcblat3 c_zblat3.f ${ZTESTL3O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
diff --git a/academic/cblas/patches/target-cleanup.diff b/academic/cblas/patches/target-cleanup.diff
index 8f15294374..bed89f0ccd 100644
--- a/academic/cblas/patches/target-cleanup.diff
+++ b/academic/cblas/patches/target-cleanup.diff
@@ -43,21 +43,6 @@ diff --git a/BLAS/SRC/CMakeLists.txt b/BLAS/SRC/CMakeLists.txt
add_library(blas ${ALLOBJ})
set_target_properties(
blas PROPERTIES
-diff --git a/CBLAS/CMakeLists.txt b/CBLAS/CMakeLists.txt
---- a/CBLAS/CMakeLists.txt
-+++ b/CBLAS/CMakeLists.txt
-@@ -65,9 +65,9 @@
- list(GET ALL_TARGETS 0 _cblas_config_build_guard_target)
- endif()
-
--configure_file(${CMAKE_CURRENT_SOURCE_DIR}/CMAKE/cblas-config-version.cmake.in
-+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cmake/cblas-config-version.cmake.in
- ${LAPACK_BINARY_DIR}/cblas-config-version.cmake @ONLY)
--configure_file(${CMAKE_CURRENT_SOURCE_DIR}/CMAKE/cblas-config-build.cmake.in
-+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cmake/cblas-config-build.cmake.in
- ${LAPACK_BINARY_DIR}/cblas-config.cmake @ONLY)
-
-
diff --git a/CBLAS/src/CMakeLists.txt b/CBLAS/src/CMakeLists.txt
--- a/CBLAS/src/CMakeLists.txt
+++ b/CBLAS/src/CMakeLists.txt
@@ -180,7 +165,7 @@ diff --git a/CBLAS/src/CMakeLists.txt b/CBLAS/src/CMakeLists.txt
+if(BUILD_COMPLEX)
+ list(APPEND ALLOBJ ${CLEV1} ${SCLEV1} ${ERRHAND} ${CLEV2} ${CLEV3})
+endif()
-+if(BUILD_COMPLEX16)
++if(BUILD_COMPLEX16)
+ list(APPEND ALLOBJ ${ZLEV1} ${DZLEV1} ${ERRHAND} ${ZLEV2} ${ZLEV3})
+endif()
+list(REMOVE_DUPLICATES ALLOBJ)
@@ -243,7 +228,7 @@ diff --git a/CBLAS/src/Makefile b/CBLAS/src/Makefile
diff --git a/CBLAS/testing/CMakeLists.txt b/CBLAS/testing/CMakeLists.txt
--- a/CBLAS/testing/CMakeLists.txt
+++ b/CBLAS/testing/CMakeLists.txt
-@@ -28,8 +28,6 @@
+@@ -27,8 +27,6 @@
# Object files for single real precision
SET( STESTL1O c_sblas1.c)
@@ -252,7 +237,7 @@ diff --git a/CBLAS/testing/CMakeLists.txt b/CBLAS/testing/CMakeLists.txt
SET( STESTL2O c_sblas2.c c_s2chke.c auxiliary.c c_xerbla.c)
SET( STESTL3O c_sblas3.c c_s3chke.c auxiliary.c c_xerbla.c)
-@@ -62,11 +60,9 @@
+@@ -61,11 +59,9 @@
add_cblas_test(stest1.out "" xscblat1)
add_cblas_test(stest2.out sin2 xscblat2)
add_cblas_test(stest3.out sin3 xscblat3)
@@ -264,7 +249,7 @@ diff --git a/CBLAS/testing/CMakeLists.txt b/CBLAS/testing/CMakeLists.txt
add_executable(xdcblat1 c_dblat1.f ${DTESTL1O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
add_executable(xdcblat2 c_dblat2.f ${DTESTL2O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
add_executable(xdcblat3 c_dblat3.f ${DTESTL3O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
-@@ -78,11 +74,9 @@
+@@ -77,11 +73,9 @@
add_cblas_test(dtest1.out "" xdcblat1)
add_cblas_test(dtest2.out din2 xdcblat2)
add_cblas_test(dtest3.out din3 xdcblat3)
@@ -276,7 +261,7 @@ diff --git a/CBLAS/testing/CMakeLists.txt b/CBLAS/testing/CMakeLists.txt
add_executable(xccblat1 c_cblat1.f ${CTESTL1O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
add_executable(xccblat2 c_cblat2.f ${CTESTL2O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
add_executable(xccblat3 c_cblat3.f ${CTESTL3O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
-@@ -94,11 +88,9 @@
+@@ -93,11 +87,9 @@
add_cblas_test(ctest1.out "" xccblat1)
add_cblas_test(ctest2.out cin2 xccblat2)
add_cblas_test(ctest3.out cin3 xccblat3)
@@ -288,7 +273,7 @@ diff --git a/CBLAS/testing/CMakeLists.txt b/CBLAS/testing/CMakeLists.txt
add_executable(xzcblat1 c_zblat1.f ${ZTESTL1O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
add_executable(xzcblat2 c_zblat2.f ${ZTESTL2O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
add_executable(xzcblat3 c_zblat3.f ${ZTESTL3O} ${LAPACK_BINARY_DIR}/include/cblas_test.h)
-@@ -110,5 +102,4 @@
+@@ -109,5 +101,4 @@
add_cblas_test(ztest1.out "" xzcblat1)
add_cblas_test(ztest2.out zin2 xzcblat2)
add_cblas_test(ztest3.out zin3 xzcblat3)
@@ -297,7 +282,7 @@ diff --git a/CBLAS/testing/CMakeLists.txt b/CBLAS/testing/CMakeLists.txt
diff --git a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -122,7 +122,33 @@
+@@ -148,7 +148,33 @@
# --------------------------------------------------
# Precision to build
# By default all precisions are generated
@@ -331,7 +316,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
# --------------------------------------------------
# Subdirectories that need to be processed
-@@ -214,10 +240,6 @@
+@@ -240,10 +266,6 @@
if(NOT LATESTLAPACK_FOUND)
message(STATUS "Using supplied NETLIB LAPACK implementation")
set( LAPACK_LIBRARIES lapack )
@@ -731,7 +716,7 @@ diff --git a/TESTING/MATGEN/CMakeLists.txt b/TESTING/MATGEN/CMakeLists.txt
endif()
if(BUILD_COMPLEX16)
- set(ALLOBJ ${ALLOBJ} ${ZMATGEN} ${DZATGEN})
-+ LIST(APPEND ALLOBJ ${ZMATGEN} ${DZATGEN})
++ list(APPEND ALLOBJ ${ZMATGEN} ${DZATGEN})
endif()
+list(REMOVE_DUPLICATES ALLOBJ)