summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Serban Udrea <S.Udrea@gsi.de>2016-08-27 00:50:43 +0700
committer David Spencer <idlemoor@slackbuilds.org>2016-08-28 00:22:40 +0100
commitc5369e951af093b2b52191909522ad37314a70df (patch)
treea98508297b4c6b04c0c46bf5361214f871609d1d /academic
parent7ffd28bfad219797c602f01cad9c01f53f97c3db (diff)
downloadslackbuilds-c5369e951af093b2b52191909522ad37314a70df.tar.gz
slackbuilds-c5369e951af093b2b52191909522ad37314a70df.tar.xz
academic/scipy3: Added (python library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/scipy3/README24
-rw-r--r--academic/scipy3/scipy3.SlackBuild91
-rw-r--r--academic/scipy3/scipy3.info10
-rw-r--r--academic/scipy3/slack-desc19
4 files changed, 144 insertions, 0 deletions
diff --git a/academic/scipy3/README b/academic/scipy3/README
new file mode 100644
index 0000000000..195c073545
--- /dev/null
+++ b/academic/scipy3/README
@@ -0,0 +1,24 @@
+SciPy (pronounced "Sigh Pie") is open-source software for mathematics,
+science, and engineering.
+
+The SciPy library is built to work with NumPy arrays, and provides many
+user-friendly and efficient numerical routines such as routines for
+numerical integration and optimization. Together, they run on all popular
+operating systems, are quick to install, and are free of charge. NumPy
+and SciPy are easy to use, but powerful enough to be depended upon by
+some of the world's leading scientists and engineers.
+
+matplotlib and ipython are nice to have in connection with scipy, but scipy
+does not depend on them.
+
+Since ver. 0.14.0 scipy uses SuperLU instead of UMFPACK for solving unsymmetric
+sparse linear systems. If you want to use UMFPACK you must install it in advance
+of numpy and build numpy accordingly (see the README to numpy's SlackBuild).
+Moreover, after installing scipy, you have to install scikit-umfpack, which
+presently is not available on SlackBuilds.org.
+
+If you need to build scipy for debugging, set DEBUG=y.
+
+NOTE: If you use this SlackBuild scipy will run with the python 3 version
+ installed on your system. If you'd like to use python 2.7.xx as
+ provided by Slackware Linux then you have to install scipy.
diff --git a/academic/scipy3/scipy3.SlackBuild b/academic/scipy3/scipy3.SlackBuild
new file mode 100644
index 0000000000..8c0af2f33c
--- /dev/null
+++ b/academic/scipy3/scipy3.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Build script for the Python SciPy package to be used with python 3
+
+# Copyright 2016 Serban Udrea <s.udrea@gsi.de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification,
+# is permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
+# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
+# INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
+
+# Written by Eugene Suter <easuter@gmail.com>
+# Updated to 0.7.2 by João Felipe Santos <joao.eel@gmail.com>
+# Updated up to 0.18.0 by Serban Udrea <S.Udrea@gsi.de>
+# Added support for building with debugging symbols (S. Udrea)
+
+PRGNAM="scipy3"
+SRCNAM="scipy"
+VERSION=${VERSION:-0.18.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf "$SRCNAM-$VERSION"
+tar xvf $CWD/$SRCNAM-$VERSION.tar.xz
+cd "$SRCNAM-$VERSION"
+chown -R root:root .
+
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+DEBUG=${DEBUG:-no}
+case "$DEBUG" in
+ [yY]|[yY][eE][sS]) DEBUG="y" ;;
+ *) DEBUG="" ;;
+esac
+
+if [ ! "$DEBUG" ]; then
+ python3 setup.py install --root $PKG
+ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+else
+ python3 setup.py build --debug
+ python3 setup.py install --root $PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt THANKS.txt INSTALL.rst.txt HACKING.rst.txt PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/scipy3/scipy3.info b/academic/scipy3/scipy3.info
new file mode 100644
index 0000000000..4799ac257e
--- /dev/null
+++ b/academic/scipy3/scipy3.info
@@ -0,0 +1,10 @@
+PRGNAM="scipy3"
+VERSION="0.18.0"
+HOMEPAGE="http://www.scipy.org/"
+DOWNLOAD="https://github.com/scipy/scipy/releases/download/v0.18.0/scipy-0.18.0.tar.xz"
+MD5SUM="59bceff108f58b0e72dfac6fb719476e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="numpy3 lapack"
+MAINTAINER="Serban Udrea"
+EMAIL="S.Udrea@gsi.de"
diff --git a/academic/scipy3/slack-desc b/academic/scipy3/slack-desc
new file mode 100644
index 0000000000..937a9df937
--- /dev/null
+++ b/academic/scipy3/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+scipy3: scipy3 (python library for math, science, and engineering)
+scipy3:
+scipy3: The SciPy library is built to work with NumPy arrays, and provides
+scipy3: many user-friendly and efficient numerical routines such as routines
+scipy3: for numerical integration and optimization. Together, they run on all
+scipy3: popular operating systems, are quick to install, and are free of
+scipy3: charge. NumPy and SciPy are easy to use, but powerful enough to be
+scipy3: depended upon by some of the world's leading scientists and engineers.
+scipy3:
+scipy3: http://www.scipy.org/
+scipy3: