summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Hunter Sezen <ovariegata@yahoo.com>2017-01-15 23:44:19 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-21 07:04:22 +0700
commit3d29039fd069efb99b15b2e6af2e020fbf4c4d13 (patch)
tree708f564c0dd3cad6a89a653e76b4f5b1460100f9 /desktop
parentc4d9cb0a33e1c7b40b92aee9e88e17f8d665d29a (diff)
downloadslackbuilds-3d29039fd069efb99b15b2e6af2e020fbf4c4d13.tar.gz
slackbuilds-3d29039fd069efb99b15b2e6af2e020fbf4c4d13.tar.xz
desktop/caffeine-ng: Added (Status bar app to stop the screensaver).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/caffeine-ng/README12
-rw-r--r--desktop/caffeine-ng/caffeine-ng.SlackBuild71
-rw-r--r--desktop/caffeine-ng/caffeine-ng.info10
-rw-r--r--desktop/caffeine-ng/doinst.sh15
-rw-r--r--desktop/caffeine-ng/slack-desc19
5 files changed, 127 insertions, 0 deletions
diff --git a/desktop/caffeine-ng/README b/desktop/caffeine-ng/README
new file mode 100644
index 0000000000..ba9d0c5d44
--- /dev/null
+++ b/desktop/caffeine-ng/README
@@ -0,0 +1,12 @@
+Caffeine is a little daemon that sits in your systray, and prevents the
+screensaver from showing up, or the system from going to sleep. It does
+so when an application is fullscreened (eg: youtube), or when you click
+on the systray icon (which you can do, when, eg: reading).
+
+This is a fork of Caffeine 2.4, since later versions dropped support
+for the systray icon in favour of automatic detection of fullscreen
+apps only.
+
+setuptools-scm is only required as a build dependency and can be
+skipped if you would rather have it automatically grabbed from
+pypi.python.org during the build process.
diff --git a/desktop/caffeine-ng/caffeine-ng.SlackBuild b/desktop/caffeine-ng/caffeine-ng.SlackBuild
new file mode 100644
index 0000000000..946b95bd70
--- /dev/null
+++ b/desktop/caffeine-ng/caffeine-ng.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for caffeine-ng
+
+# Copyright 2016-2017 Hunter Sezen California, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=caffeine-ng
+VERSION=${VERSION:-3.3.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mv $PKG/usr/share/man $PKG/usr/man
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *GPL PKG-INFO README.md requirements.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/caffeine-ng/caffeine-ng.info b/desktop/caffeine-ng/caffeine-ng.info
new file mode 100644
index 0000000000..f0174b5584
--- /dev/null
+++ b/desktop/caffeine-ng/caffeine-ng.info
@@ -0,0 +1,10 @@
+PRGNAM="caffeine-ng"
+VERSION="3.3.8"
+HOMEPAGE="https://github.com/hobarrera/caffeine-ng"
+DOWNLOAD="https://pypi.python.org/packages/c3/6a/cfceca06a9122ef92f0c5f2784a6643266c6da1a00257cae5987511b687d/caffeine-ng-3.3.8.tar.gz"
+MD5SUM="d9ea712b0012ac0606e3186adc37ffe8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="dbus-python3 docopt pyewmh pygobject3-python3 python3-xlib pyxdg setproctitle setuptools-scm wheel"
+MAINTAINER="Hunter Sezen"
+EMAIL="ovariegata@yahoo.com"
diff --git a/desktop/caffeine-ng/doinst.sh b/desktop/caffeine-ng/doinst.sh
new file mode 100644
index 0000000000..0254ea06d8
--- /dev/null
+++ b/desktop/caffeine-ng/doinst.sh
@@ -0,0 +1,15 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
+if [ -e usr/share/glib-2.0/schemas ]; then
+ if [ -x /usr/bin/glib-compile-schemas ]; then
+ /usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1
+ fi
+fi
diff --git a/desktop/caffeine-ng/slack-desc b/desktop/caffeine-ng/slack-desc
new file mode 100644
index 0000000000..2056c93dc0
--- /dev/null
+++ b/desktop/caffeine-ng/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+caffeine-ng: caffeine-ng (Status bar application to stop the screensaver)
+caffeine-ng:
+caffeine-ng: Caffeine is a little daemon that sits in your systray, and prevents
+caffeine-ng: the screensaver from showing up, or the system from going to sleep.
+caffeine-ng: It does so when an application is fullscreened (eg: youtube), or when
+caffeine-ng: you click on the systray icon (which you can do, when, eg: reading).
+caffeine-ng:
+caffeine-ng: Homepage: https://github.com/hobarrera/caffeine-ng
+caffeine-ng:
+caffeine-ng:
+caffeine-ng: