summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author David Spencer <baildon.research@googlemail.com>2016-05-31 22:25:37 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-06-01 23:54:53 +0700
commitda711b86de52d552d75083bf055ce505c981af29 (patch)
treebfe1caf7d41dd39fc8bf560a2d38b4b9bddfae6f /desktop
parent4ecda6f09b1c2c5018b35e08a6aace2b6f031613 (diff)
downloadslackbuilds-da711b86de52d552d75083bf055ce505c981af29.tar.gz
slackbuilds-da711b86de52d552d75083bf055ce505c981af29.tar.xz
desktop/qtile: Fix manpages, note deps.
Signed-off-by: David Spencer <baildon.research@googlemail.com>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/qtile/README3
-rw-r--r--desktop/qtile/qtile.SlackBuild4
2 files changed, 7 insertions, 0 deletions
diff --git a/desktop/qtile/README b/desktop/qtile/README
index ced42e39e5..3971c94b04 100644
--- a/desktop/qtile/README
+++ b/desktop/qtile/README
@@ -2,3 +2,6 @@ Qtile is simple, small, and extensible. It's easy to write your own
layouts, widgets, and built-in commands. Qtile is written and configured
entirely in Python, which means you can leverage the full power and
flexibility of the language to make it fit your needs.
+
+You will need to build cairocffi with its optional python-xcffib
+dependency.
diff --git a/desktop/qtile/qtile.SlackBuild b/desktop/qtile/qtile.SlackBuild
index e75e5ff806..1571312dbe 100644
--- a/desktop/qtile/qtile.SlackBuild
+++ b/desktop/qtile/qtile.SlackBuild
@@ -74,6 +74,10 @@ python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+mv $PKG/usr/share/man $PKG/usr/man
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
# Install an xinitrc script
mkdir -p $PKG/etc/X11/xinit
install -m 0755 $CWD/xinitrc.$PRGNAM $PKG/etc/X11/xinit/xinitrc.$PRGNAM