summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2016-08-16 06:35:09 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-08-20 07:50:03 +0700
commitdd947381cedb6e704809db16e3efc37aae6bcd69 (patch)
tree3e64eea5b1a22355d8ee4dcf8eb5c6db60d19fe8 /desktop
parentf186f2a2e350259164f978456b1aed456cdfa2d5 (diff)
downloadslackbuilds-dd947381cedb6e704809db16e3efc37aae6bcd69.tar.gz
slackbuilds-dd947381cedb6e704809db16e3efc37aae6bcd69.tar.xz
desktop/wmblob: New maintainer, minor fixes.
Diffstat (limited to 'desktop')
-rw-r--r--desktop/wmblob/README9
-rw-r--r--desktop/wmblob/wmblob.SlackBuild49
-rw-r--r--desktop/wmblob/wmblob.info4
3 files changed, 36 insertions, 26 deletions
diff --git a/desktop/wmblob/README b/desktop/wmblob/README
index 36951a0b15..a6313d90ac 100644
--- a/desktop/wmblob/README
+++ b/desktop/wmblob/README
@@ -1,4 +1,5 @@
-I'll be honest with you. The truth is: wmblob is a totally useless program. But unlike other
-totally useless programs, it looks good and shows funny moving `blobs'. I'm sure you'll like it.
-It's a nice dockapp for WindowMaker, but it's probably going to run just as well with any other
- window manager.
+I'll be honest with you. The truth is: wmblob is a totally useless
+program. But unlike other totally useless programs, it looks good
+and shows funny moving `blobs'. I'm sure you'll like it. It's a nice
+dockapp for WindowMaker, but it's probably going to run just as well
+with any other window manager.
diff --git a/desktop/wmblob/wmblob.SlackBuild b/desktop/wmblob/wmblob.SlackBuild
index 98092fe6bc..6722d69b1a 100644
--- a/desktop/wmblob/wmblob.SlackBuild
+++ b/desktop/wmblob/wmblob.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for wmblob
#
-# Copyright 2015 Gethyn ThomasQuail <gethyn@bloodbathsoftworks.com>
+# Copyright 2015 Gethyn ThomasQuail <email removed>
# All rights reserved.
#
# Based on:
@@ -25,14 +25,23 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Now maintained by B. Watson <yalhcru@gmail.com>
+
+# 20160816 bkw:
+# - took over maintenance
+# - BUILD=2
+# - install binary stripped
+# - apply SLKCFLAGS
+# - don't install INSTALL in docdir
+
PRGNAM=wmblob
VERSION=${VERSION:-1.0.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -43,8 +52,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -72,27 +81,27 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Let's compile!
./configure \
---prefix=/usr \
---libdir=/usr/lib${LIBDIRSUFFIX} \
---x-includes=/usr/include/X11 \
---x-libraries=/usr/lib/X11 \
---sysconfdir=/etc \
---localstatedir=/var \
---mandir=/usr/man \
---docdir=/usr/doc/$PRGNAM-$VERSION \
---build=$ARCH-slackware-linux
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --x-includes=/usr/include/X11 \
+ --x-libraries=/usr/lib/X11 \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+# configure ignores environment CFLAGS, so:
+sed -i "s,-O2,$SLKCFLAGS," src/Makefile
make
-make install DESTDIR=$PKG
+make install-strip DESTDIR=$PKG
-# Compresses man page
-gzip -9 $PKG/usr/man/man1/wmblob.1
+gzip -9 $PKG/usr/man/man1/$PRGNAM.1
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING INSTALL doc/how_it_works NEWS README \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING doc/how_it_works NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/desktop/wmblob/wmblob.info b/desktop/wmblob/wmblob.info
index 60d92079dd..d8f3e7bdfd 100644
--- a/desktop/wmblob/wmblob.info
+++ b/desktop/wmblob/wmblob.info
@@ -6,5 +6,5 @@ MD5SUM="0b4f9ac8cefd943e2db6882e877a971d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Gethyn ThomasQuail"
-EMAIL="gethyn@bloodbathsoftworks.com"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"