summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2016-10-15 04:53:46 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-22 08:47:29 +0700
commit5015de67683e636c501a0eae4cbe3241da031b88 (patch)
tree2712cc63b7ed21462b87fb75d52b5dae25b06c34 /development
parent43397d1dfff7b5dcf744cfb0e203e28bf107525c (diff)
downloadslackbuilds-5015de67683e636c501a0eae4cbe3241da031b88.tar.gz
slackbuilds-5015de67683e636c501a0eae4cbe3241da031b88.tar.xz
development/atasm: Updated for version 1.07d, fix man page.
Diffstat (limited to 'development')
-rw-r--r--development/atasm/README4
-rw-r--r--development/atasm/atasm.SlackBuild21
-rw-r--r--development/atasm/atasm.info6
3 files changed, 22 insertions, 9 deletions
diff --git a/development/atasm/README b/development/atasm/README
index f6d7f8db00..844b0ec16f 100644
--- a/development/atasm/README
+++ b/development/atasm/README
@@ -4,3 +4,7 @@ ATasm is a 6502 command-line cross-assembler that is compatible with the
original Mac/65 macroassembler released by OSS software. Code development
can now be performed using modern editors and compiles with lightning
speed.
+
+This build has been updated for version 1.07d (the last beta release),
+but it's still possible to build 1.06 (last stable release) by downloading
+the 1.06 source and setting VERSION=1.06 in the environment.
diff --git a/development/atasm/atasm.SlackBuild b/development/atasm/atasm.SlackBuild
index ec545079b9..c454694204 100644
--- a/development/atasm/atasm.SlackBuild
+++ b/development/atasm/atasm.SlackBuild
@@ -7,7 +7,7 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
PRGNAM=atasm
-VERSION=${VERSION:-1.06}
+VERSION=${VERSION:-1.07d}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -40,8 +40,9 @@ fi
set -e
-SRCDIR="${PRGNAM}${VERSION/./}"
-ZIPFILE="$SRCDIR.zip"
+SRCNAM="${PRGNAM}${VERSION/./}"
+ZIPFILE="$SRCNAM.zip"
+SRCDIR="$( echo "$SRCNAM" | sed 's,[a-z]$,,' )"
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -56,6 +57,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+DOCDIR=/usr/doc/$PRGNAM-$VERSION
+
+# fix reference to full documentation.
+sed -i \
+ -e "s,$PRGNAM\.txt,$PRGNAM.pdf," \
+ -e "s,%%DOCDIR%%,$DOCDIR," \
+ src/$PRGNAM.1.in
+
sed -i "s,-O3.*,$SLKCFLAGS," src/Makefile
mkdir -p $PKG/usr/bin $PKG/usr/man/man1 $PKG/usr/doc/$PRGNAM-$VERSION
@@ -66,13 +75,13 @@ touch $PRGNAM.txt
make -C src all install \
DESTDIR=$PKG/usr/bin \
MANDIR=$PKG/usr/man/man1 \
- DOCDIR=$PKG/usr/doc/$PRGNAM-$VERSION
+ DOCDIR=$PKG/$DOCDIR
strip $PKG/usr/bin/$PRGNAM
gzip $PKG/usr/man/man1/$PRGNAM.1
-rm -f $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.txt
-cp -a LICENSE *.TXT docs/* examples $PKG/usr/doc/$PRGNAM-$VERSION
+rm -f $PKG/$DOCDIR/$PRGNAM.txt
+cp -a LICENSE *.TXT docs/* examples $PKG/$DOCDIR
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/development/atasm/atasm.info b/development/atasm/atasm.info
index 6f8cabb6d1..6ed3a76672 100644
--- a/development/atasm/atasm.info
+++ b/development/atasm/atasm.info
@@ -1,8 +1,8 @@
PRGNAM="atasm"
-VERSION="1.06"
+VERSION="1.07d"
HOMEPAGE="http://atari.miribilist.com/atasm/"
-DOWNLOAD="http://downloads.sourceforge.net/project/atasm/atasm/atasm-1.06/atasm106.zip"
-MD5SUM="8019a72f5d27e4e563f433c9368a6c2c"
+DOWNLOAD="http://atari.miribilist.com/atasm/atasm107d.zip"
+MD5SUM="02c2ad750cdff8b38038ca13894b1f3c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""