summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-07-28 04:12:25 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-07-30 08:28:17 +0700
commitde80b96ce83280ddf5a0bce9dbac25a0541b1b1f (patch)
tree4d21b2482c27c84ba473d0e9d7b72302b95dc833 /development
parent595b5cf15395129a739b4481ad4d58c50276cdea (diff)
downloadslackbuilds-de80b96ce83280ddf5a0bce9dbac25a0541b1b1f.tar.gz
slackbuilds-de80b96ce83280ddf5a0bce9dbac25a0541b1b1f.tar.xz
development/wheel: Add python3 support.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'development')
-rw-r--r--development/wheel/wheel.SlackBuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/development/wheel/wheel.SlackBuild b/development/wheel/wheel.SlackBuild
index 2bc2323652..52f18a66fc 100644
--- a/development/wheel/wheel.SlackBuild
+++ b/development/wheel/wheel.SlackBuild
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true