summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-09-22 06:38:55 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-09-24 07:05:14 +0700
commit584ddc87fe9536ab73b2227d2f58d148aafe306a (patch)
tree5eb3dc33f8bc608d86f954c9ec29c06b9d1f5fca /games
parented516a9833c51354342e8cb6793c5c8c24ea83b4 (diff)
downloadslackbuilds-584ddc87fe9536ab73b2227d2f58d148aafe306a.tar.gz
slackbuilds-584ddc87fe9536ab73b2227d2f58d148aafe306a.tar.xz
games/fifengine: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'games')
-rw-r--r--games/fifengine/fifengine.SlackBuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/games/fifengine/fifengine.SlackBuild b/games/fifengine/fifengine.SlackBuild
index bf55bcba49..11462a0106 100644
--- a/games/fifengine/fifengine.SlackBuild
+++ b/games/fifengine/fifengine.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for fifengine
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,7 +67,8 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
scons
python setup.py install --root=$PKG