summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2016-10-02 16:05:44 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-08 08:07:39 +0700
commit60de9e893c0928be5936e1cacd8f3c34491f9374 (patch)
tree08d3a50bd068577604089b6941e8c00bb3cebdf8 /games
parent3d675542259b7125f0adf5caecbea3a07fdd65db (diff)
downloadslackbuilds-60de9e893c0928be5936e1cacd8f3c34491f9374.tar.gz
slackbuilds-60de9e893c0928be5936e1cacd8f3c34491f9374.tar.xz
games/trackballs: Install icons correctly.
Diffstat (limited to 'games')
-rw-r--r--games/trackballs/README6
-rw-r--r--games/trackballs/doinst.sh5
-rw-r--r--games/trackballs/slack-desc6
-rw-r--r--games/trackballs/trackballs.SlackBuild9
4 files changed, 16 insertions, 10 deletions
diff --git a/games/trackballs/README b/games/trackballs/README
index 8eb3de525f..497414136d 100644
--- a/games/trackballs/README
+++ b/games/trackballs/README
@@ -1,10 +1,10 @@
Trackballs is a marble game inspired by the 80s Atari classic Marble
Madness.
-By steering a marble ball through a labyrinth filled with sharp objecs,
-pools of acid, and other obstacles the player collects points. When
+By steering a marble ball through a labyrinth filled with sharp objects,
+pools of acid, and other obstacles, the player collects points. When
the destination is reached you continue on to the next, more difficult
-level. - unless the time runs out.
+level... unless the time runs out.
This Slackware package can include the music and/or extra levels available
at the trackballs home page: http://trackballs.sourceforge.net
diff --git a/games/trackballs/doinst.sh b/games/trackballs/doinst.sh
index 4e8ba7071d..3e5691a052 100644
--- a/games/trackballs/doinst.sh
+++ b/games/trackballs/doinst.sh
@@ -2,3 +2,8 @@ if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/games/trackballs/slack-desc b/games/trackballs/slack-desc
index 3017f2f93f..95df12983a 100644
--- a/games/trackballs/slack-desc
+++ b/games/trackballs/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
trackballs: trackballs (marble game)
trackballs:
-trackballs: Trackballs is a marble game inspired by the 80's Atari classic
+trackballs: Trackballs is a marble game inspired by the 80s Atari classic
trackballs: Marble Madness.
trackballs:
trackballs: By steering a marble ball through a labyrinth filled with sharp
-trackballs: objects, pools of acid, and other obstacles the player collects
+trackballs: objects, pools of acid, and other obstacles, the player collects
trackballs: points. When the destination is reached you continue on to the
-trackballs: next, more difficult level. - unless the time runs out.
+trackballs: next, more difficult level... unless the time runs out.
trackballs:
trackballs:
diff --git a/games/trackballs/trackballs.SlackBuild b/games/trackballs/trackballs.SlackBuild
index eee2b17dfd..8ef5025219 100644
--- a/games/trackballs/trackballs.SlackBuild
+++ b/games/trackballs/trackballs.SlackBuild
@@ -8,7 +8,7 @@
PRGNAM=trackballs
VERSION=${VERSION:-1.1.4}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -60,6 +60,9 @@ find -L . \
# another to fix "Esc" behaviour
for i in $CWD/patches/* ; do patch -p1 < $i ; done
+# Make icons honor DESTDIR (thanks to Johannes for this fix)
+sed -i 's/ $(iconsdir)/ $(DESTDIR)$(iconsdir)/g' share/icons/Makefile.in
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -76,9 +79,7 @@ make install-strip DESTDIR=$PKG
gzip $PKG/usr/man/man6/$PRGNAM.6
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
-cp -a \
- README AUTHORS COPYING ChangeLog FAQ TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README AUTHORS COPYING ChangeLog FAQ TODO $PKG/usr/doc/$PRGNAM-$VERSION
cp -a docs/*.html $PKG/usr/doc/$PRGNAM-$VERSION/html
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild