summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author David Spencer <baildon.research@googlemail.com>2016-06-09 08:16:52 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-06-10 08:02:42 +0700
commit1cd992221757ac8cba4f8d8ee5f230431c16534e (patch)
treeb139e7d80b537c466c8ed47aff979d9a2af04ccf /gis
parentc1d95803d5ebe7d4e5ad87a6170a8186b906de49 (diff)
downloadslackbuilds-1cd992221757ac8cba4f8d8ee5f230431c16534e.tar.gz
slackbuilds-1cd992221757ac8cba4f8d8ee5f230431c16534e.tar.xz
gis/gmapcatcher: Moved from network/ category.
Signed-off-by: David Spencer <baildon.research@googlemail.com>
Diffstat (limited to 'gis')
-rw-r--r--gis/gmapcatcher/README6
-rw-r--r--gis/gmapcatcher/doinst.sh3
-rw-r--r--gis/gmapcatcher/gmapcatcher.SlackBuild75
-rw-r--r--gis/gmapcatcher/gmapcatcher.info10
-rw-r--r--gis/gmapcatcher/slack-desc19
5 files changed, 113 insertions, 0 deletions
diff --git a/gis/gmapcatcher/README b/gis/gmapcatcher/README
new file mode 100644
index 0000000000..3ca0aa48d0
--- /dev/null
+++ b/gis/gmapcatcher/README
@@ -0,0 +1,6 @@
+GMapCatcher is an offline maps viewer. It downloads tiles automatically
+from many providers such as: CloudMade, OpenStreetMap, Yahoo Maps,
+Google Map. It displays them using a custom GUI. User can view the
+maps while offline. GMapCatcher doesn't depend on google-map's java
+scripts so it should work even if google changes them. It also provides
+a downloading tool.
diff --git a/gis/gmapcatcher/doinst.sh b/gis/gmapcatcher/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/gis/gmapcatcher/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/gis/gmapcatcher/gmapcatcher.SlackBuild b/gis/gmapcatcher/gmapcatcher.SlackBuild
new file mode 100644
index 0000000000..6f2c36ac36
--- /dev/null
+++ b/gis/gmapcatcher/gmapcatcher.SlackBuild
@@ -0,0 +1,75 @@
+#!/bin/sh
+
+# Slackware build script for gmapcatcher
+
+# Written by Pablo Santamaria (pablosantamaria)
+
+PRGNAM=gmapcatcher
+VERSION=${VERSION:-0.8.0.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf mapcatcher-$VERSION
+tar xvf $CWD/mapcatcher_${VERSION}.tar.gz
+cd mapcatcher-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+chmod 644 $PKG/usr/share/applications/gmapcatcher.desktop
+( cd $PKG/usr/bin ; ln -s mapcatcher gmapcatcher )
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Relocate man pages
+mv $PKG/usr/share/man $PKG/usr
+
+# Relocate docs
+mkdir -p $PKG/usr/doc
+mv $PKG/usr/share/doc/mapcatcher $PKG/usr/doc/$PRGNAM-$VERSION
+rmdir $PKG/usr/share/doc
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/gmapcatcher/gmapcatcher.info b/gis/gmapcatcher/gmapcatcher.info
new file mode 100644
index 0000000000..0b0410ae8b
--- /dev/null
+++ b/gis/gmapcatcher/gmapcatcher.info
@@ -0,0 +1,10 @@
+PRGNAM="gmapcatcher"
+VERSION="0.8.0.4"
+HOMEPAGE="http://code.google.com/p/gmapcatcher/"
+DOWNLOAD="http://gmapcatcher.googlecode.com/files/mapcatcher_0.8.0.4.tar.gz"
+MD5SUM="2485bac859e6d7f0135b47329117d301"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Pablo Santamaria"
+EMAIL="pablosantamaria@gmail.com"
diff --git a/gis/gmapcatcher/slack-desc b/gis/gmapcatcher/slack-desc
new file mode 100644
index 0000000000..612f6a7d61
--- /dev/null
+++ b/gis/gmapcatcher/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gmapcatcher: gmapcatcher (An offline map viewer)
+gmapcatcher:
+gmapcatcher: GMapCatcher is an offline maps viewer. It downloads tiles
+gmapcatcher: automatically from many providers such as: CloudMade, OpenStreetMap,
+gmapcatcher: Yahoo Maps, Google Map. It displays them using a custom GUI. User can
+gmapcatcher: view the maps while offline. GMapCatcher doesn't depend on maps's
+gmapcatcher: JavaScript so it should work even if they change them. It also
+gmapcatcher: provides a downloading tool.
+gmapcatcher:
+gmapcatcher:
+gmapcatcher: