summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2016-08-17 11:21:45 +0100
committer David Spencer <idlemoor@slackbuilds.org>2016-08-19 10:00:13 +0100
commit828f54d1d3b29549863f80c74362a5bdf1e3e4d5 (patch)
treed81c700b65c21da78d02ace9b8a8612bb6cfa163 /gis
parentfbedb744045d6efe7bd1a90e83cc98a2d11b3e81 (diff)
downloadslackbuilds-828f54d1d3b29549863f80c74362a5bdf1e3e4d5.tar.gz
slackbuilds-828f54d1d3b29549863f80c74362a5bdf1e3e4d5.tar.xz
gis/geographiclib-python: Added (Python geodesic routines).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'gis')
-rw-r--r--gis/geographiclib-python/README5
-rw-r--r--gis/geographiclib-python/geographiclib-python.SlackBuild86
-rw-r--r--gis/geographiclib-python/geographiclib-python.info10
-rw-r--r--gis/geographiclib-python/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/gis/geographiclib-python/README b/gis/geographiclib-python/README
new file mode 100644
index 0000000000..92ec5525af
--- /dev/null
+++ b/gis/geographiclib-python/README
@@ -0,0 +1,5 @@
+This is a Python implementation of the geodesic routines in GeographicLib
+(http://geographiclib.sourceforge.net/).
+
+Although it is maintained in conjunction with the larger C++ library, this
+Python package can be used independently.
diff --git a/gis/geographiclib-python/geographiclib-python.SlackBuild b/gis/geographiclib-python/geographiclib-python.SlackBuild
new file mode 100644
index 0000000000..1f6165a2ed
--- /dev/null
+++ b/gis/geographiclib-python/geographiclib-python.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+#
+# SlackBuild for geographiclib-python
+#
+# Copyright 2016 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=geographiclib
+PRGNAM=$SRCNAM-python
+VERSION=${VERSION:-1.46.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+JOBS=${JOBS:-1}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/geographiclib-python/geographiclib-python.info b/gis/geographiclib-python/geographiclib-python.info
new file mode 100644
index 0000000000..800798eb4f
--- /dev/null
+++ b/gis/geographiclib-python/geographiclib-python.info
@@ -0,0 +1,10 @@
+PRGNAM="geographiclib-python"
+VERSION="1.46.3"
+HOMEPAGE="http://geographiclib.sourceforge.net/1.46/python/"
+DOWNLOAD="https://pypi.python.org/packages/source/g/geographiclib/geographiclib-1.46.3.tar.gz"
+MD5SUM="47040ba1d4fee5d8fd871fa33cea66be"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/gis/geographiclib-python/slack-desc b/gis/geographiclib-python/slack-desc
new file mode 100644
index 0000000000..20179f1378
--- /dev/null
+++ b/gis/geographiclib-python/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+geographiclib-python: geographiclib-python (Python geodesic routines)
+geographiclib-python:
+geographiclib-python: This is a Python implementation of the geodesic routines in
+geographiclib-python: GeographicLib (http://geographiclib.sourceforge.net/).
+geographiclib-python:
+geographiclib-python:
+geographiclib-python:
+geographiclib-python:
+geographiclib-python:
+geographiclib-python:
+geographiclib-python: