summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-10-13 13:30:58 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-15 07:09:48 +0700
commit3effb16f7695b05629e1ba2c93e2e3252dcd92aa (patch)
tree6630b49d4ac42dbaa70eb2dfc9d89a9df9f7b9d4 /libraries
parent7757e8e1ed40bba36529a196f9fbb72abb4830f5 (diff)
downloadslackbuilds-3effb16f7695b05629e1ba2c93e2e3252dcd92aa.tar.gz
slackbuilds-3effb16f7695b05629e1ba2c93e2e3252dcd92aa.tar.xz
libraries/pyechonest: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/pyechonest/pyechonest.SlackBuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/libraries/pyechonest/pyechonest.SlackBuild b/libraries/pyechonest/pyechonest.SlackBuild
index 920942065b..e3b8697b51 100644
--- a/libraries/pyechonest/pyechonest.SlackBuild
+++ b/libraries/pyechonest/pyechonest.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyechonest
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,9 +67,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
$PYTHON setup.py install --root=$PKG
@@ -77,9 +77,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README.md PKG-INFO \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install