summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2016-08-12 08:28:25 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-08-13 07:22:36 +0700
commitb19bb2e455bcd6ed4da353c975d3aae5509fd063 (patch)
tree681112567fe75140e064a93cc3ef868dd933bfd7 /libraries
parent2cdb0bdae7732960d646f752159f7711bcd86071 (diff)
downloadslackbuilds-b19bb2e455bcd6ed4da353c975d3aae5509fd063.tar.gz
slackbuilds-b19bb2e455bcd6ed4da353c975d3aae5509fd063.tar.xz
libraries/platform: Updated for version 2.0.1.
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/platform/platform-2.0.1-install.patch10
-rw-r--r--libraries/platform/platform.SlackBuild13
-rw-r--r--libraries/platform/platform.info6
3 files changed, 21 insertions, 8 deletions
diff --git a/libraries/platform/platform-2.0.1-install.patch b/libraries/platform/platform-2.0.1-install.patch
new file mode 100644
index 0000000000..0c6f8f69e5
--- /dev/null
+++ b/libraries/platform/platform-2.0.1-install.patch
@@ -0,0 +1,10 @@
+diff -up ./CMakeLists.txt.orig ./CMakeLists.txt
+--- ./CMakeLists.txt.orig 2016-01-19 20:49:33.000000000 +0100
++++ ./CMakeLists.txt 2016-02-05 13:30:27.456442363 +0100
+@@ -81,5 +81,5 @@ ENDIF(NOT WIN32)
+ configure_file (platform-config.cmake.in
+ platform-config.cmake @ONLY)
+ install(FILES ${CMAKE_BINARY_DIR}/platform-config.cmake
+- DESTINATION ${CMAKE_INSTALL_LIBDIR_NOARCH}/platform)
++ DESTINATION ${CMAKE_INSTALL_LIBDIR_NOARCH}/cmake/${CMAKE_PROJECT_NAME})
+
diff --git a/libraries/platform/platform.SlackBuild b/libraries/platform/platform.SlackBuild
index e9d1b008a9..49d90b15fe 100644
--- a/libraries/platform/platform.SlackBuild
+++ b/libraries/platform/platform.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for platform
-# Copyright 2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2015-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=platform
-VERSION=${VERSION:-1.0.10}
+VERSION=${VERSION:-2.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -59,9 +59,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz 2>/dev/null || tar xvf $CWD/$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -69,6 +69,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix cmake install path.
+patch -p1 < $CWD/platform-2.0.1-install.patch
+
mkdir -p build
cd build
cmake -G "Unix Makefiles" \
diff --git a/libraries/platform/platform.info b/libraries/platform/platform.info
index 16a0d659cc..c4f0651bd5 100644
--- a/libraries/platform/platform.info
+++ b/libraries/platform/platform.info
@@ -1,8 +1,8 @@
PRGNAM="platform"
-VERSION="1.0.10"
+VERSION="2.0.1"
HOMEPAGE="https://github.com/Pulse-Eight/platform"
-DOWNLOAD="https://github.com/Pulse-Eight/platform/archive/1.0.10.tar.gz"
-MD5SUM="4ac07e020227d3cbe54351ec3837ba48"
+DOWNLOAD="https://github.com/Pulse-Eight/platform/archive/platform-2.0.1/platform-platform-2.0.1.tar.gz"
+MD5SUM="7a8df819828b657301d850eacf90d3d9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""