summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2017-01-14 06:05:37 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-14 06:05:37 +0700
commitda84d1d44fbcf53d290fab08a373019a4cf1be6d (patch)
tree2e4e4cf3b2b42ec78b4c819945b2dc9efdde94d3 /libraries
parent2f8088b8af6436ea237ec99455cace1c77eed1b2 (diff)
downloadslackbuilds-da84d1d44fbcf53d290fab08a373019a4cf1be6d.tar.gz
slackbuilds-da84d1d44fbcf53d290fab08a373019a4cf1be6d.tar.xz
libraries/unarr: Added (archive library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/unarr/CMakeLists.txt99
-rw-r--r--libraries/unarr/README7
-rw-r--r--libraries/unarr/slack-desc19
-rw-r--r--libraries/unarr/unarr.SlackBuild93
-rw-r--r--libraries/unarr/unarr.info10
5 files changed, 228 insertions, 0 deletions
diff --git a/libraries/unarr/CMakeLists.txt b/libraries/unarr/CMakeLists.txt
new file mode 100644
index 0000000000..1dceae0981
--- /dev/null
+++ b/libraries/unarr/CMakeLists.txt
@@ -0,0 +1,99 @@
+cmake_minimum_required(VERSION 2.6)
+project(unarr C)
+
+#Set up api and release version for later use.
+#Increase in major api version indicates api
+#breakage!! For non-breaking changes, use
+#minor api version instead.
+set (UNARR_API_VERSION_MAJOR 1)
+set (UNARR_API_VERSION_MINOR 0)
+
+#set build type to default if unset
+if( NOT CMAKE_BUILD_TYPE )
+ set( CMAKE_BUILD_TYPE Release CACHE STRING
+ "Choose the type of build, options are: None Debug Release RelWithDebInfo
+MinSizeRel."
+ FORCE )
+endif()
+
+find_package(ZLIB)
+find_package(BZip2)
+
+if (UNIX OR MINGW)
+ add_compile_options(-fomit-frame-pointer -D_FILE_OFFSET_BITS=64)
+endif (UNIX OR MINGW)
+
+#sources
+
+set (HEADERS common/allocator.h
+ common/unarr-imp.h
+ rar/rar.h
+ rar/lzss.h
+ rar/rarvm.h
+ lzmasdk/LzmaDec.h
+ lzmasdk/Ppmd7.h
+ lzmasdk/CpuArch.h
+ lzmasdk/Ppmd.h
+ lzmasdk/7zTypes.h
+ lzmasdk/Ppmd8.h
+ lzmasdk/Precomp.h
+ _7z/_7z.h
+ zip/zip.h
+ zip/inflate.h
+ tar/tar.h)
+
+set (SOURCES rar/uncompress-rar.c
+ rar/huffman-rar.c
+ rar/rar.c
+ rar/filter-rar.c
+ rar/rarvm.c
+ rar/parse-rar.c
+ _7z/_7z.c
+ zip/zip.c
+ zip/inflate.c
+ zip/parse-zip.c
+ zip/uncompress-zip.c
+ tar/tar.c
+ tar/parse-tar.c
+ lzmasdk/Ppmd7.c
+ lzmasdk/Ppmd8.c
+ lzmasdk/CpuArch.c
+ lzmasdk/LzmaDec.c
+ lzmasdk/Ppmd7Dec.c
+ lzmasdk/Ppmd8Dec.c
+ common/custalloc.c
+ common/unarr.c
+ common/stream.c
+ common/conv.c
+ common/crc32.c
+ )
+
+#(below is edited to process just the shared library)
+
+#build targets
+add_library(unarr SHARED unarr.h ${HEADERS} ${SOURCES})
+#add_library(unarr_static STATIC unarr.h ${HEADERS} ${SOURCES})
+set_target_properties(unarr PROPERTIES VERSION ${UNARR_API_VERSION_MAJOR}.${UNARR_API_VERSION_MINOR} SOVERSION ${UNARR_API_VERSION_MAJOR})
+#set_target_properties(unarr_static PROPERTIES OUTPUT_NAME unarr VERSION ${UNARR_API_VERSION_MAJOR}.${UNARR_API_VERSION_MINOR} SOVERSION ${UNARR_API_VERSION_MAJOR})
+
+#library detection macros
+
+if (ZLIB_FOUND)
+ include_directories(${ZLIB_INCLUDE_DIRS})
+ target_link_libraries(unarr ${ZLIB_LIBRARIES})
+# target_link_libraries(unarr_static ${ZLIB_LIBRARIES})
+ add_definitions(-DHAVE_ZLIB)
+endif(ZLIB_FOUND)
+
+if (BZIP2_FOUND)
+ include_directories(${BZIP_INCLUDE_DIRS})
+ target_link_libraries (unarr ${BZIP2_LIBRARIES})
+# target_link_libraries (unarr_static ${BZIP2_LIBRARIES})
+ add_definitions(-DHAVE_BZIP2)
+endif (BZIP2_FOUND)
+
+#make install targets
+
+install(TARGETS unarr DESTINATION lib@LIBDIRSUFFIX@)
+#install(TARGETS unarr_static DESTINATION lib@LIBDIRSUFFIX@)
+install(FILES unarr.h DESTINATION include)
diff --git a/libraries/unarr/README b/libraries/unarr/README
new file mode 100644
index 0000000000..e8767119d8
--- /dev/null
+++ b/libraries/unarr/README
@@ -0,0 +1,7 @@
+unarr is a decompression library for RAR, TAR, ZIP and 7z archives.
+
+unarr originated as a port of the RAR extraction features from
+The Unarchiver project required for extracting images from comic
+book archives (.cbr). It was written as an alternative to
+libarchive which didn't have support for parsing filters or solid
+compression at the time.
diff --git a/libraries/unarr/slack-desc b/libraries/unarr/slack-desc
new file mode 100644
index 0000000000..11a4186cbc
--- /dev/null
+++ b/libraries/unarr/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+unarr: unarr (archive library)
+unarr:
+unarr: unarr is a decompression library for RAR, TAR, ZIP and 7z archives.
+unarr:
+unarr: unarr originated as a port of the RAR extraction features from
+unarr: The Unarchiver project required for extracting images from comic
+unarr: book archives (.cbr). It was written as an alternative to
+unarr: libarchive which didn't have support for parsing filters or solid
+unarr: compression at the time.
+unarr:
+unarr: homepage: https://github.com/zeniko/unarr
diff --git a/libraries/unarr/unarr.SlackBuild b/libraries/unarr/unarr.SlackBuild
new file mode 100644
index 0000000000..2b30aaa4cf
--- /dev/null
+++ b/libraries/unarr/unarr.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/sh
+
+# Slackware build script for unarr
+
+# Copyright 2016-2017 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=unarr
+VERSION=${VERSION:-20150801_d1be8c4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+DOCS="AUTHORS COPYING README"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# The CMakeLists.txt is shamelessly stolen from Felix Kauselmann
+# https://raw.githubusercontent.com/selmf/unarr/master/CMakeLists.txt
+sed "s|@LIBDIRSUFFIX@|$LIBDIRSUFFIX|" $CWD/CMakeLists.txt > CMakeLists.txt
+
+cmake ./ -DCMAKE_INSTALL_PREFIX=/usr
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/unarr/unarr.info b/libraries/unarr/unarr.info
new file mode 100644
index 0000000000..9bf18cdb71
--- /dev/null
+++ b/libraries/unarr/unarr.info
@@ -0,0 +1,10 @@
+PRGNAM="unarr"
+VERSION="20150801_d1be8c4"
+HOMEPAGE="https://github.com/zeniko/unarr"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/unarr-20150801_d1be8c4.tar.xz"
+MD5SUM="33d3c1f85acb9e1e8228874c4a51bf2a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="p7zip"
+MAINTAINER="Matteo Bernardini"
+EMAIL="ponce@slackbuilds.org"