summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-09-27 16:19:02 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-01 07:28:39 +0700
commitdcaea59b82fd6d0c144d62d72495243239536d37 (patch)
treeaa0131ab1e53d7856214542d41c1b2cb1ba21396 /libraries
parent9cb97df51052dfcd4d625c5d1a4c07ca19241f11 (diff)
downloadslackbuilds-dcaea59b82fd6d0c144d62d72495243239536d37.tar.gz
slackbuilds-dcaea59b82fd6d0c144d62d72495243239536d37.tar.xz
libraries/guppy: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/guppy/guppy.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/libraries/guppy/guppy.SlackBuild b/libraries/guppy/guppy.SlackBuild
index 97bb3b1241..8098411032 100644
--- a/libraries/guppy/guppy.SlackBuild
+++ b/libraries/guppy/guppy.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for guppy
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py build
python setup.py install --root=$PKG