summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-09-27 04:39:01 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-01 07:28:39 +0700
commitfa58b3741598f604cb4223fa4be49cdafe64c4ba (patch)
tree5c51cd0cdf927a4584d976fa11dc4e154c3078e0 /libraries
parente5c78ec29f95b9ed2b9e3958bf05a29ae17b0e00 (diff)
downloadslackbuilds-fa58b3741598f604cb4223fa4be49cdafe64c4ba.tar.gz
slackbuilds-fa58b3741598f604cb4223fa4be49cdafe64c4ba.tar.xz
libraries/pysendfile: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/pysendfile/pysendfile.SlackBuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/libraries/pysendfile/pysendfile.SlackBuild b/libraries/pysendfile/pysendfile.SlackBuild
index 2ee3cdf04c..3bd9c6289e 100644
--- a/libraries/pysendfile/pysendfile.SlackBuild
+++ b/libraries/pysendfile/pysendfile.SlackBuild
@@ -22,7 +22,6 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
PRGNAM=pysendfile
VERSION=${VERSION:-2.0.1}
BUILD=${BUILD:-1}
@@ -30,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -41,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -68,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG