summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2016-08-15 18:48:48 +0100
committer David Spencer <idlemoor@slackbuilds.org>2016-08-15 18:48:48 +0100
commitfbedb744045d6efe7bd1a90e83cc98a2d11b3e81 (patch)
tree5097dc78d87ac406d51582c0be3e4e0d81e6bc73 /libraries
parent5c6aecd36aa253087868d7b34e08815fc90919ae (diff)
downloadslackbuilds-fbedb744045d6efe7bd1a90e83cc98a2d11b3e81.tar.gz
slackbuilds-fbedb744045d6efe7bd1a90e83cc98a2d11b3e81.tar.xz
libraries/crossguid: Added (cross platform C++ GUID/UUID library).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/crossguid/Makefile.crossguid33
-rw-r--r--libraries/crossguid/README3
-rw-r--r--libraries/crossguid/crossguid.SlackBuild91
-rw-r--r--libraries/crossguid/crossguid.info10
-rw-r--r--libraries/crossguid/slack-desc19
5 files changed, 156 insertions, 0 deletions
diff --git a/libraries/crossguid/Makefile.crossguid b/libraries/crossguid/Makefile.crossguid
new file mode 100644
index 0000000000..a9e10b8ee3
--- /dev/null
+++ b/libraries/crossguid/Makefile.crossguid
@@ -0,0 +1,33 @@
+override CXXFLAGS += -std=c++11 -DGUID_LIBUUID -fPIC
+override LDFLAGS += -luuid
+MAJOR := 0
+MINOR := 0
+VERSION := $(MAJOR).$(MINOR)
+NAME = crossguid
+
+INCLUDEDIR = /usr/include
+LIBDIR = /usr/lib
+
+LINK.o = $(LINK.cc)
+
+SRC = $(wildcard *.cpp)
+OBJ = $(SRC:.cpp=.o)
+LIB = lib$(NAME).so.$(VERSION)
+
+$(LIB): guid.o
+ $(CXX) $(LDFLAGS) -shared -Wl,-soname,lib$(NAME).so.$(MAJOR) $^ -o $@
+
+test: $(OBJ)
+
+install: guid.h $(LIB)
+ install -dm 0755 $(DESTDIR)$(INCLUDEDIR)
+ install -pm 0644 guid.h $(DESTDIR)$(INCLUDEDIR)
+ install -dm 0755 $(DESTDIR)$(LIBDIR)
+ install -pm 0755 $(LIB) $(DESTDIR)$(LIBDIR)
+ ln -sf $(LIB) $(DESTDIR)$(LIBDIR)/lib$(NAME).so
+ ln -sf $(LIB) $(DESTDIR)$(LIBDIR)/lib$(NAME).so.$(MAJOR)
+
+clean:
+ $(RM) $(OBJ) $(LIB) test
+
+.PHONY: run-test install clean
diff --git a/libraries/crossguid/README b/libraries/crossguid/README
new file mode 100644
index 0000000000..06bdd5027a
--- /dev/null
+++ b/libraries/crossguid/README
@@ -0,0 +1,3 @@
+CrossGuid is a minimal, cross platform, C++ GUID library. It uses the best
+native GUID/UUID generator on the given platform and had a generic class for
+parsing, stringifying, and comparing IDs.
diff --git a/libraries/crossguid/crossguid.SlackBuild b/libraries/crossguid/crossguid.SlackBuild
new file mode 100644
index 0000000000..728009a65a
--- /dev/null
+++ b/libraries/crossguid/crossguid.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for crossguid
+
+# Copyright 2016 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=crossguid
+VERSION=${VERSION:-20150308}
+MD5SHORT=8f399e8
+MD5LONG=8f399e8bd4252be9952f3dfa8199924cc8487ca4
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$MD5LONG
+tar xvf $CWD/$PRGNAM-$MD5SHORT.tar.gz 2>/dev/null || tar xvf $CWD/$PRGNAM-$MD5LONG.tar.gz
+cd $PRGNAM-$MD5LONG
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cp -a $CWD/Makefile.$PRGNAM Makefile
+
+CXXFLAGS="$SLKCFLAGS" \
+make
+make install DESTDIR=$PKG LIBDIR=/usr/lib${LIBDIRSUFFIX}
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/crossguid/crossguid.info b/libraries/crossguid/crossguid.info
new file mode 100644
index 0000000000..2f65534164
--- /dev/null
+++ b/libraries/crossguid/crossguid.info
@@ -0,0 +1,10 @@
+PRGNAM="crossguid"
+VERSION="20150308"
+HOMEPAGE="https://github.com/graeme-hill/crossguid"
+DOWNLOAD="https://github.com/graeme-hill/crossguid/archive/8f399e8/crossguid-8f399e8.tar.gz"
+MD5SUM="696a6573286d6fdbfde18686aa9f6489"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/libraries/crossguid/slack-desc b/libraries/crossguid/slack-desc
new file mode 100644
index 0000000000..5e971dff6f
--- /dev/null
+++ b/libraries/crossguid/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+crossguid: crossguid (Lightweight cross platform C++ GUID/UUID library)
+crossguid:
+crossguid: CrossGuid is a minimal, cross platform, C++ GUID library. It uses the
+crossguid: best native GUID/UUID generator on the given platform and had a
+crossguid: generic class for parsing, stringifying, and comparing IDs.
+crossguid:
+crossguid: Homepage: https://github.com/graeme-hill/crossguid
+crossguid:
+crossguid:
+crossguid:
+crossguid: