summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
author Hunter Sezen <ovariegata@yahoo.com>2016-12-28 18:01:09 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-12-31 08:22:11 +0700
commit0c69abab35d14280798df227599e27e202b73c1d (patch)
tree8ae30dd6b1a344e2d6390d76e6871a6041b67586 /misc
parent8bf90e160c38946500a057c13d20876bf38c09c7 (diff)
downloadslackbuilds-0c69abab35d14280798df227599e27e202b73c1d.tar.gz
slackbuilds-0c69abab35d14280798df227599e27e202b73c1d.tar.xz
misc/grabc: Added (X11 pixel color grabber).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/grabc/Makefile.diff.gzbin0 -> 573 bytes
-rw-r--r--misc/grabc/README4
-rw-r--r--misc/grabc/grabc.SlackBuild92
-rw-r--r--misc/grabc/grabc.info10
-rw-r--r--misc/grabc/slack-desc19
5 files changed, 125 insertions, 0 deletions
diff --git a/misc/grabc/Makefile.diff.gz b/misc/grabc/Makefile.diff.gz
new file mode 100644
index 0000000000..cda30b2594
--- /dev/null
+++ b/misc/grabc/Makefile.diff.gz
Binary files differ
diff --git a/misc/grabc/README b/misc/grabc/README
new file mode 100644
index 0000000000..9f54a8c5cf
--- /dev/null
+++ b/misc/grabc/README
@@ -0,0 +1,4 @@
+grabc is s simple but very useful program to determine the color
+string in hex (or in RGB components) by clicking on a pixel on the
+screen. While web browsing, lots of time you find a nice color and
+wonder what color is that! Well just use grabc!
diff --git a/misc/grabc/grabc.SlackBuild b/misc/grabc/grabc.SlackBuild
new file mode 100644
index 0000000000..055eefbb18
--- /dev/null
+++ b/misc/grabc/grabc.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for grabc
+
+# Copyright 2016 Hunter Sezen California, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=grabc
+VERSION=${VERSION:-1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM$VERSION
+tar xvf $CWD/$PRGNAM$VERSION.tar.gz
+cd $PRGNAM$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+zcat $CWD/Makefile.diff.gz | patch -p1
+
+CFLAGS="$SLKCFLAGS" make \
+ X11LIB=/usr/X11R6/lib${LIBDIRSUFFIX}
+
+make install \
+ PREFIX=/usr \
+ DOCDIR=/usr/doc/$PRGNAM-$VERSION \
+ DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/misc/grabc/grabc.info b/misc/grabc/grabc.info
new file mode 100644
index 0000000000..43cd56d84d
--- /dev/null
+++ b/misc/grabc/grabc.info
@@ -0,0 +1,10 @@
+PRGNAM="grabc"
+VERSION="1.1"
+HOMEPAGE="http://www.muquit.com/muquit/software/grabc/grabc.html"
+DOWNLOAD="http://www.muquit.com/muquit/software/grabc/grabc1.1.tar.gz"
+MD5SUM="d8d308f3183c719309f35c249db4f9ed"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Hunter Sezen"
+EMAIL="ovariegata@yahoo.com"
diff --git a/misc/grabc/slack-desc b/misc/grabc/slack-desc
new file mode 100644
index 0000000000..539be0765f
--- /dev/null
+++ b/misc/grabc/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+grabc: grabc (X11 pixel color grabber)
+grabc:
+grabc: grabc is s simple but very useful program to determine the color
+grabc: string in hex (or in RGB components) by clicking on a pixel on the
+grabc: screen.
+grabc:
+grabc: Homepage: http://www.muquit.com/muquit/software/grabc/grabc.html
+grabc:
+grabc:
+grabc:
+grabc: