summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-04 03:33:08 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-07 08:48:19 +0700
commit8c6f048ecdb6ec0894a32b4b0f9845a59acca121 (patch)
treec1044c47ff1e88fd1ca0b61ada8bf9ead321b8cb /misc
parent4b5c6e3efc97580389969f96e24cfe3cb38aefd6 (diff)
downloadslackbuilds-8c6f048ecdb6ec0894a32b4b0f9845a59acca121.tar.gz
slackbuilds-8c6f048ecdb6ec0894a32b4b0f9845a59acca121.tar.xz
misc/protobuf3: Added (Google's data interchange format)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/protobuf3/README28
-rw-r--r--misc/protobuf3/protobuf3.SlackBuild115
-rw-r--r--misc/protobuf3/protobuf3.info12
-rw-r--r--misc/protobuf3/slack-desc19
4 files changed, 174 insertions, 0 deletions
diff --git a/misc/protobuf3/README b/misc/protobuf3/README
new file mode 100644
index 0000000000..3c70ca0ab0
--- /dev/null
+++ b/misc/protobuf3/README
@@ -0,0 +1,28 @@
+protobuf3 (Google's data interchange format)
+
+Protocol buffers are a flexible, efficient, automated mechanism for
+serializing structured data.
+
+This package contains protobuf API version 3.
+It support the following language implementations:
+* C++
+* Java
+* Python
+* Objective-C
+* C#
+* JavaNano
+* JavaScript
+* Ruby
+* Go
+* PHP (Alpha)
+
+The complete documentation for Protocol Buffers is available at:
+https://developers.google.com/protocol-buffers/
+
+NOTE:
+* This package should NOT be installed alongside with protobuf.
+ Protobuf3 introduced API incompatibility and upstream will
+ continue to support protobuf version 2.
+* Protobuf3 enforces strict UTF-8 checking.
+ Parsing will fail if a string field contains non UTF-8 data.
+* This SlackBuild installs the Python bindings by default.
diff --git a/misc/protobuf3/protobuf3.SlackBuild b/misc/protobuf3/protobuf3.SlackBuild
new file mode 100644
index 0000000000..9e09822181
--- /dev/null
+++ b/misc/protobuf3/protobuf3.SlackBuild
@@ -0,0 +1,115 @@
+#!/bin/sh
+
+# Slackware build script for protobuf3
+
+# Copyright 2017 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=protobuf3
+VERSION=${VERSION:-3.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+GTEST=googletest-release
+GTESTVERSION=${GTESTVERSION:-1.8.0}
+
+SRCNAM=protobuf
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+tar xvf $CWD/$GTEST-$GTESTVERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Avoid downloading gtest automatically
+# It doesn't detect system-wide gtest installation
+rm -rf gmock googletest
+cp -rf ../$GTEST-$GTESTVERSION/googlemock gmock
+cp -rf ../$GTEST-$GTESTVERSION/googletest googletest
+ln -sf ../googletest gmock/gtest
+
+./autogen.sh
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --disable-static \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --enable-static=no \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+# Install the python bindings
+cd python ; python setup.py install --root=$PKG ; cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a BUILD *.txt LICENSE *.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/misc/protobuf3/protobuf3.info b/misc/protobuf3/protobuf3.info
new file mode 100644
index 0000000000..2bbf62727e
--- /dev/null
+++ b/misc/protobuf3/protobuf3.info
@@ -0,0 +1,12 @@
+PRGNAM="protobuf3"
+VERSION="3.1.0"
+HOMEPAGE="https://github.com/google/protobuf"
+DOWNLOAD="https://github.com/google/protobuf/archive/v3.1.0/protobuf-3.1.0.tar.gz \
+ https://github.com/google/googletest/archive/release-1.8.0/googletest-release-1.8.0.tar.gz"
+MD5SUM="14a532a7538551d5def317bfca41dace \
+ 16877098823401d1bf2ed7891d7dce36"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Willy Sudiarto Raharjo"
+EMAIL="willysr@slackbuilds.org"
diff --git a/misc/protobuf3/slack-desc b/misc/protobuf3/slack-desc
new file mode 100644
index 0000000000..440a1c6d9a
--- /dev/null
+++ b/misc/protobuf3/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+protobuf3: protobuf3 (Google's data interchange format)
+protobuf3:
+protobuf3: Protocol Buffers are Google's language-neutral, platform-neutral,
+protobuf3: extensible mechanism for serializing structured data.
+protobuf3:
+protobuf3: This package contains protobuf API version 3.
+protobuf3:
+protobuf3:
+protobuf3: Project URL: https://github.com/google/protobuf
+protobuf3:
+protobuf3: