summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
author Rafael Tavares <mdrafaeltavares@gmail.com>2016-07-27 11:58:19 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-07-30 06:03:43 +0700
commitb51d81c15eb5831d0c12c447b4ea74acde1605b8 (patch)
tree014061ca00356bd26125e29ca94f214d893cd494 /misc
parent645f171659f1890ea1b2a51fad2c5b0eddafbd45 (diff)
downloadslackbuilds-b51d81c15eb5831d0c12c447b4ea74acde1605b8.tar.gz
slackbuilds-b51d81c15eb5831d0c12c447b4ea74acde1605b8.tar.xz
misc/bbrun: Added (Run Utility for BlackBox).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/bbrun/README1
-rw-r--r--misc/bbrun/bbrun.SlackBuild78
-rw-r--r--misc/bbrun/bbrun.info10
-rw-r--r--misc/bbrun/patches/bbrun-1.6-list.patch127
-rw-r--r--misc/bbrun/patches/bbrun-1.6-makefile.patch29
-rw-r--r--misc/bbrun/slack-desc19
6 files changed, 264 insertions, 0 deletions
diff --git a/misc/bbrun/README b/misc/bbrun/README
new file mode 100644
index 0000000000..5941bd9d1c
--- /dev/null
+++ b/misc/bbrun/README
@@ -0,0 +1 @@
+A old (but gold) tool for blackbox or other desktop manager.
diff --git a/misc/bbrun/bbrun.SlackBuild b/misc/bbrun/bbrun.SlackBuild
new file mode 100644
index 0000000000..fa427c7476
--- /dev/null
+++ b/misc/bbrun/bbrun.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/sh
+
+# Slackware build script for bbrun
+
+# Copyright 2016 Rafael Tavares (mdrafaeltavares@gmail.com) Bahia, Brazil.
+# Patches provided by Gentoo Linux.
+# https://gitweb.gentoo.org/repo/gentoo.git/tree/x11-misc/bbrun/files
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=bbrun
+VERSION=${VERSION:-1.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+CWD=$(pwd)
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xfv $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p0 -i $CWD/patches/$PRGNAM-$VERSION-list.patch
+patch -p0 -i $CWD/patches/$PRGNAM-$VERSION-makefile.patch
+
+cd $PRGNAM
+make
+
+mkdir -p $PKG/usr/bin
+cp bbrun $PKG/usr/bin
+
+cd ..
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING Changelog CREDITS README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/bbrun.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/bbrun.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/misc/bbrun/bbrun.info b/misc/bbrun/bbrun.info
new file mode 100644
index 0000000000..cab36d32bf
--- /dev/null
+++ b/misc/bbrun/bbrun.info
@@ -0,0 +1,10 @@
+PRGNAM="bbrun"
+VERSION="1.6"
+HOMEPAGE="http://darkops.net"
+DOWNLOAD="ftp://ftp.slackware.com/.2/gentoo/distfiles/bbrun-1.6.tar.gz"
+MD5SUM="820960e3d52ddf2d5cf7e4ba51821bfd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Rafael Tavares"
+EMAIL="mdrafaeltavares@gmail.com"
diff --git a/misc/bbrun/patches/bbrun-1.6-list.patch b/misc/bbrun/patches/bbrun-1.6-list.patch
new file mode 100644
index 0000000000..654b4f6814
--- /dev/null
+++ b/misc/bbrun/patches/bbrun-1.6-list.patch
@@ -0,0 +1,127 @@
+diff -Naur wmgeneral.orig/list.c wmgeneral/list.c
+--- wmgeneral.orig/list.c 2002-02-05 18:36:19.000000000 +0100
++++ wmgeneral/list.c 2016-01-04 12:54:39.666670005 +0100
+@@ -38,7 +38,7 @@
+
+ /* Return a cons cell produced from (head . tail) */
+
+-INLINE LinkedList*
++LinkedList*
+ list_cons(void* head, LinkedList* tail)
+ {
+ LinkedList* cell;
+@@ -51,7 +51,7 @@
+
+ /* Return the length of a list, list_length(NULL) returns zero */
+
+-INLINE int
++int
+ list_length(LinkedList* list)
+ {
+ int i = 0;
+@@ -66,7 +66,7 @@
+ /* Return the Nth element of LIST, where N count from zero. If N
+ larger than the list length, NULL is returned */
+
+-INLINE void*
++void*
+ list_nth(int index, LinkedList* list)
+ {
+ while(index-- != 0)
+@@ -81,7 +81,7 @@
+
+ /* Remove the element at the head by replacing it by its successor */
+
+-INLINE void
++void
+ list_remove_head(LinkedList** list)
+ {
+ if (!*list) return;
+@@ -101,7 +101,7 @@
+
+ /* Remove the element with `car' set to ELEMENT */
+ /*
+-INLINE void
++void
+ list_remove_elem(LinkedList** list, void* elem)
+ {
+ while (*list)
+@@ -112,7 +112,7 @@
+ }
+ }*/
+
+-INLINE LinkedList *
++LinkedList *
+ list_remove_elem(LinkedList* list, void* elem)
+ {
+ LinkedList *tmp;
+@@ -132,7 +132,7 @@
+
+ /* Return element that has ELEM as car */
+
+-INLINE LinkedList*
++LinkedList*
+ list_find(LinkedList* list, void* elem)
+ {
+ while(list)
+@@ -146,7 +146,7 @@
+
+ /* Free list (backwards recursive) */
+
+-INLINE void
++void
+ list_free(LinkedList* list)
+ {
+ if(list)
+@@ -158,7 +158,7 @@
+
+ /* Map FUNCTION over all elements in LIST */
+
+-INLINE void
++void
+ list_mapcar(LinkedList* list, void(*function)(void*))
+ {
+ while(list)
+diff -Naur wmgeneral.orig/list.h wmgeneral/list.h
+--- wmgeneral.orig/list.h 2002-02-05 18:36:19.000000000 +0100
++++ wmgeneral/list.h 2016-01-04 12:54:39.666670005 +0100
+@@ -29,31 +29,25 @@
+ #ifndef __LIST_H_
+ #define __LIST_H_
+
+-#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
+-# define INLINE inline
+-#else
+-# define INLINE
+-#endif
+-
+ typedef struct LinkedList {
+ void *head;
+ struct LinkedList *tail;
+ } LinkedList;
+
+-INLINE LinkedList* list_cons(void* head, LinkedList* tail);
++LinkedList* list_cons(void* head, LinkedList* tail);
+
+-INLINE int list_length(LinkedList* list);
++int list_length(LinkedList* list);
+
+-INLINE void* list_nth(int index, LinkedList* list);
++void* list_nth(int index, LinkedList* list);
+
+-INLINE void list_remove_head(LinkedList** list);
++void list_remove_head(LinkedList** list);
+
+-INLINE LinkedList *list_remove_elem(LinkedList* list, void* elem);
++LinkedList *list_remove_elem(LinkedList* list, void* elem);
+
+-INLINE void list_mapcar(LinkedList* list, void(*function)(void*));
++void list_mapcar(LinkedList* list, void(*function)(void*));
+
+-INLINE LinkedList*list_find(LinkedList* list, void* elem);
++LinkedList*list_find(LinkedList* list, void* elem);
+
+-INLINE void list_free(LinkedList* list);
++void list_free(LinkedList* list);
+
+ #endif
diff --git a/misc/bbrun/patches/bbrun-1.6-makefile.patch b/misc/bbrun/patches/bbrun-1.6-makefile.patch
new file mode 100644
index 0000000000..cf89b96df6
--- /dev/null
+++ b/misc/bbrun/patches/bbrun-1.6-makefile.patch
@@ -0,0 +1,29 @@
+Respect {C,LD}FLAGS, fix underlinking
+
+http://bugs.gentoo.org/367853
+
+--- bbrun/Makefile
++++ bbrun/Makefile
+@@ -1,7 +1,7 @@
+ CC = gcc
+ LIBDIR = -L/usr/lib -L/usr/X11R6/lib
+-LIBS = -lXpm `pkg-config --libs gtk+-2.0`
+-CFLAGS = `pkg-config --cflags gtk+-2.0`
++LIBS = `pkg-config --libs xext xpm gtk+-2.0`
++DEP_CFLAGS = `pkg-config --cflags xext xpm gtk+-2.0`
+
+ OBJS = bbrun.o \
+ ../wmgeneral/wmgeneral.o \
+@@ -11,10 +11,10 @@
+ all: bbrun
+
+ .c.o:
+- $(CC) -g -c -O2 -Wall $< -o $*.o $(CFLAGS)
++ $(CC) $(CFLAGS) $(DEP_CFLAGS) -c -Wall $< -o $*.o
+
+ bbrun: $(OBJS)
+- $(CC) -Wall -g -o bbrun $^ $(LIBDIR) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -Wall -o bbrun $^ $(LIBDIR) $(LIBS)
+
+ install:
+ cp bbrun /usr/local/bin/
diff --git a/misc/bbrun/slack-desc b/misc/bbrun/slack-desc
new file mode 100644
index 0000000000..f8632df947
--- /dev/null
+++ b/misc/bbrun/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+bbrun: BBrun (A run utility for BlackBox)
+bbrun:
+bbrun: BBrun is a run utility for BlackBox which can be run in the slit
+bbrun: or in withdrawn mode so that it can be bound to a keystroke from
+bbrun: bbkeys. It also features a history list of the most recent commands.
+bbrun:
+bbrun:
+bbrun:
+bbrun:
+bbrun:
+bbrun: