summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Andrew Clemons <andrew.clemons@gmail.com>2016-11-21 22:30:22 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-11-26 11:47:24 +0700
commit23d9f920ea277357ba8e058ce9d8e07ffcc4814e (patch)
tree54cc9379a89aa3923d8e08ae3fb83b129ac546b2 /network
parent82ba59b6c9241d891a8cfd41777968f7c66dd712 (diff)
downloadslackbuilds-23d9f920ea277357ba8e058ce9d8e07ffcc4814e.tar.gz
slackbuilds-23d9f920ea277357ba8e058ce9d8e07ffcc4814e.tar.xz
network/imapfilter: Updated for version 2.6.7 + new maintainer.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/imapfilter/README15
-rw-r--r--network/imapfilter/imapfilter.SlackBuild61
-rw-r--r--network/imapfilter/imapfilter.info12
-rw-r--r--network/imapfilter/slack-desc14
4 files changed, 61 insertions, 41 deletions
diff --git a/network/imapfilter/README b/network/imapfilter/README
index 48011a5f0c..2f588db01b 100644
--- a/network/imapfilter/README
+++ b/network/imapfilter/README
@@ -1,8 +1,11 @@
IMAPFilter (a mail filtering utility)
-IMAPFilter connects to remote mail servers using the Internet
-Message Access Protocol (IMAP), sends searching queries to the
-server and processes mailboxes based on the results. It can be used
-to delete, copy, move, flag, etc. messages residing in mailboxes at
-the same or different mail servers. The 4rev1 and 4 versions of the
-IMAP protocol are supported.
+IMAPFilter is a mail filtering utility. It connects to remote mail
+servers using the Internet Message Access Protocol (IMAP), sends
+searching queries to the server and processes mailboxes based on the
+results. It can be used to delete, copy, move, flag, etc. messages
+residing in mailboxes at the same or different mail servers. The
+4rev1 and 4 versions of the IMAP protocol are supported.
+
+IMAPFilter uses the Lua programming language as a configuration and
+extension language. <https://github.com/lefcha/imapfilter>
diff --git a/network/imapfilter/imapfilter.SlackBuild b/network/imapfilter/imapfilter.SlackBuild
index ef5103b12e..98ea79e011 100644
--- a/network/imapfilter/imapfilter.SlackBuild
+++ b/network/imapfilter/imapfilter.SlackBuild
@@ -1,16 +1,36 @@
#!/bin/sh
-# Slackware build script for IMAPFilter
-# Written by Šime Ramov <s@ramov.com>
+# Slackware build script for imapfilter
+
+# Copyright 2010 Šime Ramov
+# Copyright 2016 Andrew Clemons, Wellington, New Zealand
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=imapfilter
-VERSION=${VERSION:-2.2.2}
+VERSION=${VERSION:-2.6.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -21,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -41,32 +61,29 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xzf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i "s/\(MYCFLAGS =\)/\1 $SLKCFLAGS/" src/Makefile
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure -p /usr
-make
-make install DESTDIR=$PKG
+make PREFIX=/usr all
+make PREFIX=/usr DESTDIR=$PKG MANDIR=/usr/man install
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- LICENSE NEWS README sample.* \
+ AUTHORS LICENSE Makefile NEWS README samples \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/network/imapfilter/imapfilter.info b/network/imapfilter/imapfilter.info
index faed20ade8..dccfd108c8 100644
--- a/network/imapfilter/imapfilter.info
+++ b/network/imapfilter/imapfilter.info
@@ -1,10 +1,10 @@
PRGNAM="imapfilter"
-VERSION="2.2.2"
-HOMEPAGE="http://imapfilter.hellug.gr/"
-DOWNLOAD="http://imapfilter.hellug.gr/source/imapfilter-2.2.2.tar.gz"
-MD5SUM="d917416499f4dd5a0112f7fb89523a97"
+VERSION="2.6.7"
+HOMEPAGE="https://github.com/lefcha/imapfilter"
+DOWNLOAD="https://github.com/lefcha/imapfilter/archive/v2.6.7/imapfilter-2.6.7.tar.gz"
+MD5SUM="3843adf279122ed8d666a6855ba4e7c8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="lua"
-MAINTAINER="Šime Ramov"
-EMAIL="s@ramov.com"
+MAINTAINER="Andrew Clemons"
+EMAIL="andrew.clemons@gmail.com"
diff --git a/network/imapfilter/slack-desc b/network/imapfilter/slack-desc
index 1d47716d6b..ab5ba58b81 100644
--- a/network/imapfilter/slack-desc
+++ b/network/imapfilter/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
imapfilter: imapfilter (a mail filtering utility)
imapfilter:
-imapfilter: IMAPFilter connects to remote mail servers using the Internet
-imapfilter: Message Access Protocol (IMAP), sends searching queries to the
-imapfilter: server and processes mailboxes based on the results. It can be used
-imapfilter: to delete, copy, move, flag, etc. messages residing in mailboxes at
-imapfilter: the same or different mail servers.
+imapfilter: IMAPFilter is a mail filtering utility. It connects to remote mail
+imapfilter: servers using the Internet Message Access Protocol (IMAP), sends
+imapfilter: searching queries to the server and processes mailboxes based on the
+imapfilter: results. It can be used to delete, copy, move, flag, etc. messages
+imapfilter: residing in mailboxes at the same or different mail servers. The
+imapfilter: 4rev1 and 4 versions of the IMAP protocol are supported.
imapfilter:
imapfilter: IMAPFilter uses the Lua programming language as a configuration and
-imapfilter: extension language. <http://imapfilter.hellug.gr/>
-imapfilter:
+imapfilter: extension language. <https://github.com/lefcha/imapfilter>