summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Barry J. Grundy <bgrundyat>2016-08-27 00:51:48 +0700
committer David Spencer <idlemoor@slackbuilds.org>2016-08-28 00:22:40 +0100
commit3918dcef7bc7fd44dd32aaeb0791c38da4e7c119 (patch)
tree5741d38df9792a898fcb34c324a38c3a786eb2c7 /network
parente8bba789c9d9f0e50088bf9e686d619166c329ca (diff)
downloadslackbuilds-3918dcef7bc7fd44dd32aaeb0791c38da4e7c119.tar.gz
slackbuilds-3918dcef7bc7fd44dd32aaeb0791c38da4e7c119.tar.xz
network/tcpflow: Added (data capture).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/tcpflow/README12
-rw-r--r--network/tcpflow/slack-desc19
-rw-r--r--network/tcpflow/tcpflow.SlackBuild101
-rw-r--r--network/tcpflow/tcpflow.info10
4 files changed, 142 insertions, 0 deletions
diff --git a/network/tcpflow/README b/network/tcpflow/README
new file mode 100644
index 0000000000..b4421a9e36
--- /dev/null
+++ b/network/tcpflow/README
@@ -0,0 +1,12 @@
+tcpflow is a program that captures data transmitted as part of TCP connections
+(flows), and stores the data in a way that is convenient for protocol analysis
+and debugging. Each TCP flow is stored in its own file. Thus, the typical TCP
+flow will be stored in two files, one for each direction. tcpflow can also
+process stored 'tcpdump' packet flows.
+
+tcpflow is similar to 'tcpdump', in that both process packets from the wire or
+from a stored file. But it's different in that it reconstructs the actual data
+streams and stores each flow in a separate file for later analysis.
+
+tcpflow understands sequence numbers and will correctly reconstruct data
+streams regardless of retransmissions or out-of-order delivery.
diff --git a/network/tcpflow/slack-desc b/network/tcpflow/slack-desc
new file mode 100644
index 0000000000..582716f359
--- /dev/null
+++ b/network/tcpflow/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+tcpflow: tcpflow (data capture)
+tcpflow:
+tcpflow: tcpflow is a program that captures data transmitted as part of TCP
+tcpflow: connections (flows) and stores the data in a way that is convenient
+tcpflow: for protocol analysis and debugging. Each TCP flow is stored in its
+tcpflow: own file. Thus, the typical TCP flow will be stored in two files
+tcpflow: one for each direction. tcpflow can also process stored tcpdump
+tcpflow: packet flows.
+tcpflow:
+tcpflow: https://github.com/simsong/tcpflow/
+tcpflow:
diff --git a/network/tcpflow/tcpflow.SlackBuild b/network/tcpflow/tcpflow.SlackBuild
new file mode 100644
index 0000000000..2cc04773d8
--- /dev/null
+++ b/network/tcpflow/tcpflow.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/sh
+
+# Slackware build script for tcpflow
+
+# Copyright 2016 Barry J. Grundy <bgrundy@linuxleo.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Initial Slackbuild v1.4.5 August, 2016
+# Barry J. Grundy <bgrundy(at)linuxleo.com>
+
+PRGNAM=tcpflow
+VERSION=${VERSION:-1.4.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --build=$ARCH-slackware-linux
+
+make
+make install-strip DESTDIR=$PKG
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS ChangeLog INSTALL README TODO.txt doc $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+rm -f $PKG/usr/doc/$PRGNAM-$VERSION/docs/Makefile*
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/tcpflow/tcpflow.info b/network/tcpflow/tcpflow.info
new file mode 100644
index 0000000000..c89e018f3b
--- /dev/null
+++ b/network/tcpflow/tcpflow.info
@@ -0,0 +1,10 @@
+PRGNAM="tcpflow"
+VERSION="1.4.5"
+HOMEPAGE="https://github.com/simsong/tcpflow/"
+DOWNLOAD="http://digitalcorpora.org/downloads/tcpflow/tcpflow-1.4.5.tar.gz"
+MD5SUM="5978b112a899f2099e98cef6d9a0ece9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Barry J. Grundy"
+EMAIL="bgrundy<at>linuxleo.com"