summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Brenton Earl <brent@exitstatusone.com>2016-07-22 01:34:08 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-07-24 07:27:50 +0700
commitccc72cee9c8953f50772749d0ded2600c3aa4b10 (patch)
treef1881f90beb99a97c2d0ba19860abfe19fae728c /network
parent0a608a1e045c63e8b1968d3db3e3e70fafb7c293 (diff)
downloadslackbuilds-ccc72cee9c8953f50772749d0ded2600c3aa4b10.tar.gz
slackbuilds-ccc72cee9c8953f50772749d0ded2600c3aa4b10.tar.xz
network/ufw: Updated for version 0.35.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/ufw/ufw-0.35-fix-iptables-path.patch20
-rw-r--r--network/ufw/ufw.SlackBuild33
-rw-r--r--network/ufw/ufw.conf.patch11
-rw-r--r--network/ufw/ufw.conf.patch.gzbin322 -> 0 bytes
-rw-r--r--network/ufw/ufw.info10
5 files changed, 65 insertions, 9 deletions
diff --git a/network/ufw/ufw-0.35-fix-iptables-path.patch b/network/ufw/ufw-0.35-fix-iptables-path.patch
new file mode 100644
index 0000000000..d81cd1744b
--- /dev/null
+++ b/network/ufw/ufw-0.35-fix-iptables-path.patch
@@ -0,0 +1,20 @@
+--- a/src/util.py.orig 2016-07-21 16:16:45.785925215 -0600
++++ b/src/util.py 2016-07-21 17:33:12.716614138 -0600
+@@ -727,7 +727,7 @@
+ return network == orig_network
+
+
+-def get_iptables_version(exe="/sbin/iptables"):
++def get_iptables_version(exe="/usr/sbin/iptables"):
+ '''Return iptables version'''
+ (rc, out) = cmd([exe, '-V'])
+ if rc != 0:
+@@ -737,7 +737,7 @@
+
+
+ # must be root, so don't report coverage in unit tests
+-def get_netfilter_capabilities(exe="/sbin/iptables", do_checks=True):
++def get_netfilter_capabilities(exe="/usr/sbin/iptables", do_checks=True):
+ '''Return capabilities set for netfilter to support new features. Callers
+ must be root.'''
+ def test_cap(exe, chain, rule):
diff --git a/network/ufw/ufw.SlackBuild b/network/ufw/ufw.SlackBuild
index e56edc6620..7882a0b57e 100644
--- a/network/ufw/ufw.SlackBuild
+++ b/network/ufw/ufw.SlackBuild
@@ -1,15 +1,38 @@
#!/bin/sh
+
# Slackware build script for ufw
-# Written by Marco Cecchetti (mrc.ildp@gmail.com)
+
+# Copyright 2010 Marco Cecchetti <mrc.ildp@gmail.com>
+# Copyright 2013 Ricardson Williams <ricardsonwilliams@gmail.com>
+# Copyright 2014-2015 Rodolfo Gouveia <rgouveia@cosmico.net>
+# Copyright 2016 Brenton Earl <brent@exitstatusone.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ufw
-VERSION=${VERSION:-0.33}
+VERSION=${VERSION:-0.35}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -21,6 +44,7 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
@@ -34,7 +58,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-zcat $CWD/ufw.conf.patch.gz | patch -p1 --verbose
+patch -p1 --verbose < $CWD/ufw.conf.patch
+patch -p1 --verbose < $CWD/ufw-0.35-fix-iptables-path.patch
python setup.py install --root=$PKG
diff --git a/network/ufw/ufw.conf.patch b/network/ufw/ufw.conf.patch
new file mode 100644
index 0000000000..0b085ae82b
--- /dev/null
+++ b/network/ufw/ufw.conf.patch
@@ -0,0 +1,11 @@
+--- ufw-0.33.orig/conf/ufw.conf 2012-08-18 05:12:49.000000000 +0800
++++ ufw-0.33/conf/ufw.conf 2013-07-16 04:18:44.365425697 +0800
+@@ -3,7 +3,7 @@
+
+ # Set to yes to start on boot. If setting this remotely, be sure to add a rule
+ # to allow your remote connection before starting ufw. Eg: 'ufw allow 22/tcp'
+-ENABLED=no
++ENABLED=yes
+
+ # Please use the 'ufw' command to set the loglevel. Eg: 'ufw logging medium'.
+ # See 'man ufw' for details.
diff --git a/network/ufw/ufw.conf.patch.gz b/network/ufw/ufw.conf.patch.gz
deleted file mode 100644
index 220a20b03a..0000000000
--- a/network/ufw/ufw.conf.patch.gz
+++ /dev/null
Binary files differ
diff --git a/network/ufw/ufw.info b/network/ufw/ufw.info
index 8fedbc37ab..a65a7c07a8 100644
--- a/network/ufw/ufw.info
+++ b/network/ufw/ufw.info
@@ -1,10 +1,10 @@
PRGNAM="ufw"
-VERSION="0.33"
+VERSION="0.35"
HOMEPAGE="https://launchpad.net/ufw"
-DOWNLOAD="https://launchpad.net/ufw/0.33/0.33/+download/ufw-0.33.tar.gz"
-MD5SUM="3747b453d76709e5a99da209fc0bb5f5"
+DOWNLOAD="https://launchpad.net/ufw/0.35/0.35/+download/ufw-0.35.tar.gz"
+MD5SUM="b7cd2dd4e4e98e46df125fee06edff92"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="rodolfo gouveia"
-EMAIL="rgouveia@cosmico.net"
+MAINTAINER="Brenton Earl"
+EMAIL="brent@exitstatusone.com"