summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Alexander Verbovetsky <alik@ejik.org>2017-01-11 20:56:53 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-11 20:56:53 +0700
commitac42931c41e0a3f63655624be43f64e3b8de5b36 (patch)
treec7a77101635ae047abad68340034a7ccc8fce54f /office
parente1534e5676b8a7691f2bd89aa8ebd8b4157d562e (diff)
downloadslackbuilds-ac42931c41e0a3f63655624be43f64e3b8de5b36.tar.gz
slackbuilds-ac42931c41e0a3f63655624be43f64e3b8de5b36.tar.xz
office/smoffice2016: Added (office suite).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/smoffice2016/README18
-rw-r--r--office/smoffice2016/README.SBo22
-rw-r--r--office/smoffice2016/doinst.sh13
-rw-r--r--office/smoffice2016/planmaker1614
-rw-r--r--office/smoffice2016/pml16.dsk.add7
-rw-r--r--office/smoffice2016/presentations1621
-rw-r--r--office/smoffice2016/prl16.dsk.add7
-rw-r--r--office/smoffice2016/slack-desc19
-rw-r--r--office/smoffice2016/smoffice2016.SlackBuild128
-rw-r--r--office/smoffice2016/smoffice2016.info10
-rw-r--r--office/smoffice2016/textmaker1620
-rw-r--r--office/smoffice2016/tml16.dsk.add7
12 files changed, 286 insertions, 0 deletions
diff --git a/office/smoffice2016/README b/office/smoffice2016/README
new file mode 100644
index 0000000000..2187827dab
--- /dev/null
+++ b/office/smoffice2016/README
@@ -0,0 +1,18 @@
+SoftMaker Office 2016 is an office suite, it includes
+
+ * TextMaker 2016, a word processor
+ * PlanMaker 2016, a spreadsheet program
+ * Presentations 2016, a presentation software
+
+The main feature of SoftMaker Office 2016 is the extremely high
+compatibility with the MS Office file formats.
+
+SoftMaker Office 2016 is a commercial program. It is available in
+Standard and Pro editions, and also as a free 30 days trial.
+
+The SoftMaker Office 2016 is a 32-bit software, it can be built on both
+32-bit and 64-bit machines, but to run it on 64-bit machine, you will
+need a multilib system.
+
+If you don't run KDE/GNOME, please see README.SBo for a description of
+some GUI options.
diff --git a/office/smoffice2016/README.SBo b/office/smoffice2016/README.SBo
new file mode 100644
index 0000000000..f4c2214d66
--- /dev/null
+++ b/office/smoffice2016/README.SBo
@@ -0,0 +1,22 @@
+If you don't run KDE/GNOME the SoftMaker Office may fail to detect the
+GUI settings you use, for example the menu fonts will not be
+anti-aliased regardless of settings of fontconfig, and so on.
+
+In this case try to start TextMaker (or PlanMaker or Presentations) with
+one of the following two undocumented options:
+-gui:gnome
+-gui:kde
+for example:
+$ textmaker16 -gui:gnome
+
+Also, please set "Linux (system colors)" under
+Tools > Options > Appearance > Dialog style.
+
+To use one of these two options permanently, put the corresponding word
+"gnome" or "kde" to the configuration file
+~/.smoffice_gui.conf (for a given user) or/and
+/etc/smoffice_gui.conf (system wide)
+
+References:
+http://forum.softmaker.de/viewtopic.php?t=11192#p51932
+http://forum.softmaker.de/viewtopic.php?t=21226
diff --git a/office/smoffice2016/doinst.sh b/office/smoffice2016/doinst.sh
new file mode 100644
index 0000000000..aea0f894eb
--- /dev/null
+++ b/office/smoffice2016/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/office/smoffice2016/planmaker16 b/office/smoffice2016/planmaker16
new file mode 100644
index 0000000000..6c50f83ffa
--- /dev/null
+++ b/office/smoffice2016/planmaker16
@@ -0,0 +1,14 @@
+#!/bin/sh
+# A script to run PlanMaker.
+
+GUI=-gui:$( \
+if [ -r ~/.smoffice_gui.conf ]; then \
+ cat ~/.smoffice_gui.conf; \
+else \
+ [ -r /etc/smoffice_gui.conf ] && cat /etc/smoffice_gui.conf; \
+fi | grep -o -m1 "gnome\|kde" | head -n1)
+
+case "$GUI" in
+ -gui:gnome|-gui:kde) /opt/smoffice2016/planmaker "$GUI" "$@" ;;
+ *) /opt/smoffice2016/planmaker "$@" ;;
+esac
diff --git a/office/smoffice2016/pml16.dsk.add b/office/smoffice2016/pml16.dsk.add
new file mode 100644
index 0000000000..cd221dd8e6
--- /dev/null
+++ b/office/smoffice2016/pml16.dsk.add
@@ -0,0 +1,7 @@
+Version=1.0
+Name=PlanMaker 2016
+Icon=application-x-pml16
+TryExec=/usr/bin/planmaker16
+StartupWMClass=pm
+Exec=/usr/bin/planmaker16 %F
+Path=/opt/smoffice2016
diff --git a/office/smoffice2016/presentations16 b/office/smoffice2016/presentations16
new file mode 100644
index 0000000000..36f2898ce3
--- /dev/null
+++ b/office/smoffice2016/presentations16
@@ -0,0 +1,21 @@
+#!/bin/bash
+# A script to run Presentations.
+
+GUI=-gui:$( \
+if [ -r ~/.smoffice_gui.conf ]; then \
+ cat ~/.smoffice_gui.conf; \
+else \
+ [ -r /etc/smoffice_gui.conf ] && cat /etc/smoffice_gui.conf; \
+fi | grep -o -m1 "gnome\|kde" | head -n1)
+
+case "$GUI" in
+ -gui:gnome|-gui:kde) cmd="/opt/smoffice2016/presentations $GUI" ;;
+ *) cmd="/opt/smoffice2016/presentations" ;;
+esac
+
+ext="${@##*.}"
+shopt -s nocasematch
+case "$ext" in
+ prs|pps|ppsx) $cmd -S\""$@"\";;
+ * ) $cmd "$@";;
+esac
diff --git a/office/smoffice2016/prl16.dsk.add b/office/smoffice2016/prl16.dsk.add
new file mode 100644
index 0000000000..ac14d817f2
--- /dev/null
+++ b/office/smoffice2016/prl16.dsk.add
@@ -0,0 +1,7 @@
+Version=1.0
+Name=Presentations 2016
+Icon=application-x-prl16
+TryExec=/usr/bin/presentations16
+StartupWMClass=pr
+Exec=/usr/bin/presentations16 %F
+Path=/opt/smoffice2016
diff --git a/office/smoffice2016/slack-desc b/office/smoffice2016/slack-desc
new file mode 100644
index 0000000000..ff12ae3a6b
--- /dev/null
+++ b/office/smoffice2016/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+smoffice2016: smoffice2016 (office suite)
+smoffice2016:
+smoffice2016: SoftMaker Office 2016 includes
+smoffice2016: * TextMaker 2016, a word processor
+smoffice2016: * PlanMaker 2016, a spreadsheet program
+smoffice2016: * Presentations 2016, a presentation software
+smoffice2016:
+smoffice2016: The main feature of SoftMaker Office 2016 is the extremely high
+smoffice2016: compatibility with the MS Office file formats.
+smoffice2016:
+smoffice2016: Home page: http://www.softmaker.com/en/softmaker-office-linux
diff --git a/office/smoffice2016/smoffice2016.SlackBuild b/office/smoffice2016/smoffice2016.SlackBuild
new file mode 100644
index 0000000000..f2d2fae381
--- /dev/null
+++ b/office/smoffice2016/smoffice2016.SlackBuild
@@ -0,0 +1,128 @@
+#!/bin/sh
+
+# Slackware build script for smoffice2016
+
+# Based on the Arch Linux PKGBUILD.
+
+# Copyright 2017, Alexander Verbovetsky, Moscow, Russia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=smoffice2016
+VERSION=${VERSION:-2016_763}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+case "$ARCH" in
+ i586) ;;
+ x86_64) cat << EOF
+To run SoftMaker Office on 64-bit machine, you will need a multilib system.
+EOF
+ ARCH=i586 ;;
+ *) echo "$ARCH is not supported."
+ exit 1 ;;
+esac
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG/opt/smoffice2016 $OUTPUT
+cd $TMP
+tar xvf $CWD/softmaker-office-${VERSION//_/-}.tgz
+tar xvf office.tgz -C $PKG/opt/smoffice2016
+cd $PKG
+mv opt/smoffice2016/usr/lib/dpf opt/smoffice2016
+rm -r opt/smoffice2016/usr
+ln -s libdpf.so.2.8.0 opt/smoffice2016/dpf/libdpf.so.2
+
+LNG=`echo $LANG|cut -f 1 -d"_" 2>/dev/null`
+case "$LNG" in
+ de) ;;
+ es) ;;
+ *) LNG="en" ;;
+esac
+mv opt/smoffice2016/spell/langenscheidt_$LNG.thn \
+ opt/smoffice2016/spell/langenscheidt.thn
+rm opt/smoffice2016/spell/langenscheidt_*.thn
+
+mkdir -p usr/bin
+install -m 0755 -o root -g root $CWD/planmaker16 usr/bin
+install -m 0755 -o root -g root $CWD/presentations16 usr/bin
+install -m 0755 -o root -g root $CWD/textmaker16 usr/bin
+
+for s in 16 32 48 64 128; do
+ mkdir -p usr/share/icons/hicolor/${s}x${s}/{apps,mimetypes}
+ for a in pml prl tml; do
+ cp -a opt/smoffice2016/icons/${a}_${s}.png \
+ usr/share/icons/hicolor/${s}x${s}/apps/application-x-${a}16.png
+ done
+ for a in pmd prd tmd; do
+ cp -a opt/smoffice2016/icons/${a}_${s}.png \
+ usr/share/icons/hicolor/${s}x${s}/mimetypes/application-x-${a}.png
+ done
+done
+
+mkdir -p usr/share/applications
+mv opt/smoffice2016/mime/pml16.dsk \
+ usr/share/applications/planmaker-2016.desktop
+mv opt/smoffice2016/mime/prl16.dsk \
+ usr/share/applications/presentations-2016.desktop
+mv opt/smoffice2016/mime/tml16.dsk \
+ usr/share/applications/textmaker-2016.desktop
+cat $CWD/pml16.dsk.add >> usr/share/applications/planmaker-2016.desktop
+cat $CWD/prl16.dsk.add >> usr/share/applications/presentations-2016.desktop
+cat $CWD/tml16.dsk.add >> usr/share/applications/textmaker-2016.desktop
+
+mkdir -p usr/share/mime/packages/
+cp -a opt/smoffice2016/mime/softmaker-office-2016.xml \
+ usr/share/mime/packages/
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p usr/doc/$PRGNAM-$VERSION
+mv opt/smoffice2016/*.pdf opt/smoffice2016/mime/copyright \
+ usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p install
+cat $CWD/slack-desc > install/slack-desc
+cat $CWD/doinst.sh > install/doinst.sh
+
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/smoffice2016/smoffice2016.info b/office/smoffice2016/smoffice2016.info
new file mode 100644
index 0000000000..bf585a5f83
--- /dev/null
+++ b/office/smoffice2016/smoffice2016.info
@@ -0,0 +1,10 @@
+PRGNAM="smoffice2016"
+VERSION="2016_763"
+HOMEPAGE="http://www.softmaker.com/en/softmaker-office-linux"
+DOWNLOAD="http://www.softmaker.net/down/softmaker-office-2016-763.tgz"
+MD5SUM="1d3e7ac1c58f2f08a6e42ad04a1b0cf7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Alexander Verbovetsky"
+EMAIL="alik@ejik.org"
diff --git a/office/smoffice2016/textmaker16 b/office/smoffice2016/textmaker16
new file mode 100644
index 0000000000..c1c334cd08
--- /dev/null
+++ b/office/smoffice2016/textmaker16
@@ -0,0 +1,20 @@
+#!/bin/sh
+# A script to run TextMaker.
+
+GUI=-gui:$( \
+if [ -r ~/.smoffice_gui.conf ]; then \
+ cat ~/.smoffice_gui.conf; \
+else \
+ [ -r /etc/smoffice_gui.conf ] && cat /etc/smoffice_gui.conf; \
+fi | grep -o -m1 "gnome\|kde" | head -n1)
+
+case "$GUI" in
+ -gui:gnome|-gui:kde)
+ LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/smoffice2016/dpf \
+ /opt/smoffice2016/textmaker "$GUI" "$@"
+ ;;
+ *)
+ LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/smoffice2016/dpf \
+ /opt/smoffice2016/textmaker "$@"
+ ;;
+esac
diff --git a/office/smoffice2016/tml16.dsk.add b/office/smoffice2016/tml16.dsk.add
new file mode 100644
index 0000000000..68bcf67ab6
--- /dev/null
+++ b/office/smoffice2016/tml16.dsk.add
@@ -0,0 +1,7 @@
+Version=1.0
+Name=TextMaker 2016
+Icon=application-x-tml16
+TryExec=/usr/bin/textmaker16
+StartupWMClass=tm
+Exec=/usr/bin/textmaker16 %F
+Path=/opt/smoffice2016