summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2017-01-24 14:21:54 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-28 07:38:34 +0700
commitc974d2e630c7ac0825d8cdf8c2d486df7462bec4 (patch)
treedbee6ae490d11580797f9145e00554ba47faf265 /office
parent468a62df1534c8975ceb9ad0cbf16eade5b5a376 (diff)
downloadslackbuilds-c974d2e630c7ac0825d8cdf8c2d486df7462bec4.tar.gz
slackbuilds-c974d2e630c7ac0825d8cdf8c2d486df7462bec4.tar.xz
office/juffed: Updated for version 0.10.
Added the optional dependency enca, cleanups Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/juffed/README4
-rw-r--r--office/juffed/juffed.SlackBuild57
-rw-r--r--office/juffed/juffed.info6
3 files changed, 36 insertions, 31 deletions
diff --git a/office/juffed/README b/office/juffed/README
index 59e54037f4..b322d42743 100644
--- a/office/juffed/README
+++ b/office/juffed/README
@@ -1,6 +1,6 @@
-juffed (light qt editor)
-
JuffEd is a free, cross-platform text editor for programmers and
advanced users. Has syntax highlighting for many languages, code
folding, find/replace using plain text and regexps, code completion,
multiple charsets and many other useful features.
+
+enca is an optional dependency (for auto language detection).
diff --git a/office/juffed/juffed.SlackBuild b/office/juffed/juffed.SlackBuild
index b0d70dcbf5..2b12832e30 100644
--- a/office/juffed/juffed.SlackBuild
+++ b/office/juffed/juffed.SlackBuild
@@ -1,16 +1,36 @@
#!/bin/sh
# Slackware build script for juffed
-# Written by Matteo Bernardini <ponce@slackbuilds.org>
+
+# Copyright 2011-2017 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
PRGNAM=juffed
-VERSION=${VERSION:-0.8.1}
+VERSION=${VERSION:-0.10}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -21,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -43,19 +63,14 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/${PRGNAM}_${VERSION}.tar.?z*
+tar xvf $CWD/${PRGNAM}-${VERSION}-1054.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# respect our $LIBDIRSUFFIX
-sed -i \
- "s|\${CMAKE_INSTALL_PREFIX}/lib|\${CMAKE_INSTALL_PREFIX}/lib${LIBDIRSUFFIX}|" \
- CMakeLists.txt
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
mkdir -p build
cd build
@@ -63,22 +78,12 @@ cd build
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=$LIBDIRSUFFIX \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
cd ..
-# the binary isn't able to find libQscintilla, I guess because it should be have a link
-# in /usr/lib${LIBDIRSUFFIX}. Try a workaround with a simple wrapper that calls the
-# original binary renamed -orig.
-mv $PKG/usr/bin/$PRGNAM $PKG/usr/bin/$PRGNAM-orig
-cat <<EOF > $PKG/usr/bin/$PRGNAM
-#!/bin/sh
-export LD_LIBRARY_PATH=/usr/lib${LIBDIRSUFFIX}/qt/lib/:\${LD_LIBRARY_PATH}
-exec $PRGNAM-orig "\$@"
-EOF
-chmod +x $PKG/usr/bin/$PRGNAM
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/office/juffed/juffed.info b/office/juffed/juffed.info
index 7e5b860c07..a9a8d3b42d 100644
--- a/office/juffed/juffed.info
+++ b/office/juffed/juffed.info
@@ -1,8 +1,8 @@
PRGNAM="juffed"
-VERSION="0.8.1"
+VERSION="0.10"
HOMEPAGE="http://juffed.com"
-DOWNLOAD="http://downloads.sourceforge.net/juffed/juffed_0.8.1.tar.bz2"
-MD5SUM="bf012e468e22e945230e5ddb8c94d740"
+DOWNLOAD="http://downloads.sourceforge.net/juffed/juffed-0.10-1054.tar.bz2"
+MD5SUM="33ca5c94fd4aedb9925e58f8f9ba9a7c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""