summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author David Spencer <baildon.research@googlemail.com>2016-12-29 08:38:11 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-12-31 08:22:11 +0700
commit0eb4c4947d3b25cbf400127b1cfb34282e7e5c7e (patch)
treeb67c396ed0b81a8da05a2304ae59c3689c8ada68 /python
parentba71539ea380337a466795d39c93a47813c6e972 (diff)
downloadslackbuilds-0eb4c4947d3b25cbf400127b1cfb34282e7e5c7e.tar.gz
slackbuilds-0eb4c4947d3b25cbf400127b1cfb34282e7e5c7e.tar.xz
python/python-libarchive-c: Added (Python interface to libarchive).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-libarchive-c/README6
-rw-r--r--python/python-libarchive-c/python-libarchive-c.SlackBuild92
-rw-r--r--python/python-libarchive-c/python-libarchive-c.info10
-rw-r--r--python/python-libarchive-c/slack-desc19
4 files changed, 127 insertions, 0 deletions
diff --git a/python/python-libarchive-c/README b/python/python-libarchive-c/README
new file mode 100644
index 0000000000..18140cad38
--- /dev/null
+++ b/python/python-libarchive-c/README
@@ -0,0 +1,6 @@
+python-libarchive-c is a Python interface to libarchive.
+
+python3 is an optional dependency. You need to set PYTHON3=yes,
+for example:
+
+ PYTHON3=yes ./python-libarchive-c.SlackBuild
diff --git a/python/python-libarchive-c/python-libarchive-c.SlackBuild b/python/python-libarchive-c/python-libarchive-c.SlackBuild
new file mode 100644
index 0000000000..7e687042de
--- /dev/null
+++ b/python/python-libarchive-c/python-libarchive-c.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for python-libarchive-c
+
+# Copyright 2016 David Spencer, Baildon, West Yorkshire, U.K.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-libarchive-c
+VERSION=${VERSION:-2.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+if [ "${PYTHON3:-no}" == "yes" ]; then
+ rm -rf build
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-libarchive-c/python-libarchive-c.info b/python/python-libarchive-c/python-libarchive-c.info
new file mode 100644
index 0000000000..a3d64b99d5
--- /dev/null
+++ b/python/python-libarchive-c/python-libarchive-c.info
@@ -0,0 +1,10 @@
+PRGNAM="python-libarchive-c"
+VERSION="2.7"
+HOMEPAGE="https://github.com/Changaco/python-libarchive-c"
+DOWNLOAD="https://pypi.python.org/packages/1f/4a/7421e8db5c7509cf75e34b92a32b69c506f2b6f6392a909c2f87f3e94ad2/libarchive-c-2.7.tar.gz"
+MD5SUM="6c23d0e2cc235a58bc5181f70f880375"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="David Spencer"
+EMAIL="baildon.research@googlemail.com"
diff --git a/python/python-libarchive-c/slack-desc b/python/python-libarchive-c/slack-desc
new file mode 100644
index 0000000000..fe8c59624d
--- /dev/null
+++ b/python/python-libarchive-c/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-libarchive-c: python-libarchive-c (Python interface to libarchive)
+python-libarchive-c:
+python-libarchive-c: python-libarchive-c is a Python interface to libarchive.
+python-libarchive-c:
+python-libarchive-c: https://github.com/Changaco/python-libarchive-c
+python-libarchive-c:
+python-libarchive-c:
+python-libarchive-c:
+python-libarchive-c:
+python-libarchive-c:
+python-libarchive-c: