summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@liwjatan.at>2017-01-14 01:13:13 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-14 01:13:13 +0700
commit1991fc3eb054de838754f2eb827e88d0823a7f8a (patch)
treea037b164468e97ecf3a92b04c3f8dad9ca0a4e1f /python
parent6cf070500874fd8b1e59e012726977cc1a3eec42 (diff)
downloadslackbuilds-1991fc3eb054de838754f2eb827e88d0823a7f8a.tar.gz
slackbuilds-1991fc3eb054de838754f2eb827e88d0823a7f8a.tar.xz
python/python-gattlib: Added (Bluetooth LE protocol library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-gattlib/README3
-rw-r--r--python/python-gattlib/python-gattlib.SlackBuild73
-rw-r--r--python/python-gattlib/python-gattlib.info10
-rw-r--r--python/python-gattlib/slack-desc19
4 files changed, 105 insertions, 0 deletions
diff --git a/python/python-gattlib/README b/python/python-gattlib/README
new file mode 100644
index 0000000000..ab2b73dfa0
--- /dev/null
+++ b/python/python-gattlib/README
@@ -0,0 +1,3 @@
+This is a Python library to use the GATT Protocol for Bluetooth LE
+devices. It is a wrapper around the implementation used by gatttool
+in bluez package.
diff --git a/python/python-gattlib/python-gattlib.SlackBuild b/python/python-gattlib/python-gattlib.SlackBuild
new file mode 100644
index 0000000000..d099800241
--- /dev/null
+++ b/python/python-gattlib/python-gattlib.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for python-gattlib
+
+# Copyright 2017 Heinz Wiesinger, Amsterdam, The Netherlands
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-gattlib
+VERSION=${VERSION:-0.20150805}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=gattlib
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-gattlib/python-gattlib.info b/python/python-gattlib/python-gattlib.info
new file mode 100644
index 0000000000..a44ffd366c
--- /dev/null
+++ b/python/python-gattlib/python-gattlib.info
@@ -0,0 +1,10 @@
+PRGNAM="python-gattlib"
+VERSION="0.20150805"
+HOMEPAGE="https://bitbucket.org/OscarAcena/pygattlib"
+DOWNLOAD="https://pypi.python.org/packages/be/2f/5b1aecec551b42b59d8b399ad444b5672972efb590ca83d784dbe616a3e1/gattlib-0.20150805.tar.gz"
+MD5SUM="f620eca190bb7acd67c7aafecaedb6c2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Heinz Wiesinger"
+EMAIL="pprkut@liwjatan.at"
diff --git a/python/python-gattlib/slack-desc b/python/python-gattlib/slack-desc
new file mode 100644
index 0000000000..bf1e8b2ae3
--- /dev/null
+++ b/python/python-gattlib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-gattlib: python-gattlib (Bluetooth LE protocol library)
+python-gattlib:
+python-gattlib: This is a Python library to use the GATT Protocol for Bluetooth LE
+python-gattlib: devices. It is a wrapper around the implementation used by gatttool
+python-gattlib: in bluez package.
+python-gattlib:
+python-gattlib: Homepage: https://bitbucket.org/OscarAcena/pygattlib
+python-gattlib:
+python-gattlib:
+python-gattlib:
+python-gattlib: