summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2017-01-24 20:35:02 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-28 07:38:01 +0700
commit28c8ec819c5c269990a9421cf9e36ff68f3ed2c6 (patch)
tree1d04532815f5e0f46d5e01913042a80d998772d5 /python
parent36a8b3db41ba562bd36328af932ae19ec4b878f1 (diff)
downloadslackbuilds-28c8ec819c5c269990a9421cf9e36ff68f3ed2c6.tar.gz
slackbuilds-28c8ec819c5c269990a9421cf9e36ff68f3ed2c6.tar.xz
python/testpath: Added (Test utilities for files and commands).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/testpath/README5
-rw-r--r--python/testpath/setup.py13
-rw-r--r--python/testpath/slack-desc19
-rw-r--r--python/testpath/testpath.SlackBuild88
-rw-r--r--python/testpath/testpath.info10
5 files changed, 135 insertions, 0 deletions
diff --git a/python/testpath/README b/python/testpath/README
new file mode 100644
index 0000000000..b69bea0585
--- /dev/null
+++ b/python/testpath/README
@@ -0,0 +1,5 @@
+Testpath is a collection of utilities for Python code working with files and
+commands.
+
+It contains functions to check things on the filesystem, and tools for mocking
+system commands and recording calls to those.
diff --git a/python/testpath/setup.py b/python/testpath/setup.py
new file mode 100644
index 0000000000..9fc1264e45
--- /dev/null
+++ b/python/testpath/setup.py
@@ -0,0 +1,13 @@
+
+from setuptools import setup, find_packages
+
+setup(
+ name='testpath',
+ version='0.3',
+ description='Test utilities for Python code working with files and commands',
+ url='https://github.com/jupyter/testpath',
+ author='The Jupyter Development Team',
+ license='MIT',
+ long_description='Test utilities for Python code working with files and commands',
+ packages=find_packages(exclude=['tests'])
+)
diff --git a/python/testpath/slack-desc b/python/testpath/slack-desc
new file mode 100644
index 0000000000..f8f9b674d0
--- /dev/null
+++ b/python/testpath/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+testpath: testpath (Test utilities for code working with files and commands)
+testpath:
+testpath: testpath is a collection of utilities for Python code working with
+testpath: files and commands.
+testpath:
+testpath:
+testpath:
+testpath:
+testpath:
+testpath:
+testpath:
diff --git a/python/testpath/testpath.SlackBuild b/python/testpath/testpath.SlackBuild
new file mode 100644
index 0000000000..60dc7f8c23
--- /dev/null
+++ b/python/testpath/testpath.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for testpath
+
+# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=testpath
+VERSION=${VERSION:-0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cp $CWD/setup.py .
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/testpath/testpath.info b/python/testpath/testpath.info
new file mode 100644
index 0000000000..4acafed76f
--- /dev/null
+++ b/python/testpath/testpath.info
@@ -0,0 +1,10 @@
+PRGNAM="testpath"
+VERSION="0.3"
+HOMEPAGE="https://github.com/jupyter/testpath"
+DOWNLOAD="https://github.com/jupyter/testpath/archive/0.3/testpath-0.3.tar.gz"
+MD5SUM="c5237d3ab1c8b1471376179322065548"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"