summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-08-19 19:20:43 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-08-20 07:49:48 +0700
commit2b42e20408ddc33e05c96a4424bf6ad3846b1855 (patch)
tree0423f212d06a764ee4ad0cb9513a26bf52fc386a /python
parenta8358d5ba463a0e62b11ed49d4fed67fbba61e85 (diff)
downloadslackbuilds-2b42e20408ddc33e05c96a4424bf6ad3846b1855.tar.gz
slackbuilds-2b42e20408ddc33e05c96a4424bf6ad3846b1855.tar.xz
python/pyqode.qt: Added (Wrapper library for PyQt and PySIde).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pyqode.qt/README8
-rw-r--r--python/pyqode.qt/pyqode.qt.SlackBuild85
-rw-r--r--python/pyqode.qt/pyqode.qt.info10
-rw-r--r--python/pyqode.qt/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/python/pyqode.qt/README b/python/pyqode.qt/README
new file mode 100644
index 0000000000..b698286237
--- /dev/null
+++ b/python/pyqode.qt/README
@@ -0,0 +1,8 @@
+pyqode.qt is a shim that let you write libraries/applications that
+supports both PyQt and PySide.
+
+We provide support for PyQt5, PyQt4 and PySide using the PyQt5 layout
+(where the QtGui module has been split into QtGui and QtWidgets).
+
+Basically, you write your code as if you were using PyQt5 but import
+qt from pyqode.qt instead of PyQt5.
diff --git a/python/pyqode.qt/pyqode.qt.SlackBuild b/python/pyqode.qt/pyqode.qt.SlackBuild
new file mode 100644
index 0000000000..a59092de3e
--- /dev/null
+++ b/python/pyqode.qt/pyqode.qt.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for pyqode.qt
+
+# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyqode.qt
+VERSION=${VERSION:-2.10.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst LICENSE AUTHORS.rst CHANGELOG.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyqode.qt/pyqode.qt.info b/python/pyqode.qt/pyqode.qt.info
new file mode 100644
index 0000000000..bc8ca6d1a2
--- /dev/null
+++ b/python/pyqode.qt/pyqode.qt.info
@@ -0,0 +1,10 @@
+PRGNAM="pyqode.qt"
+VERSION="2.10.0"
+HOMEPAGE="https://github.com/pyQode/pyqode.qt"
+DOWNLOAD="https://pypi.python.org/packages/d4/15/f1e4f2e12e114e32eb35bc7bd49a67ff94d6b1a0f1471f49ea04aa1e5b56/pyqode.qt-2.10.0.tar.gz"
+MD5SUM="bd999d85a513c657c3ea4b1dd7e9b0c5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64="python3-PyQt5"
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/pyqode.qt/slack-desc b/python/pyqode.qt/slack-desc
new file mode 100644
index 0000000000..f289a16740
--- /dev/null
+++ b/python/pyqode.qt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pyqode.qt: pyqode.qt (Wrapper library for PyQt and PySIde)
+pyqode.qt:
+pyqode.qt: pyqode.qt is a shim that let you write libraries/applications that
+pyqode.qt: supports both PyQt and PySide.
+pyqode.qt:
+pyqode.qt: Homepage: https://github.com/pyQode/pyqode.qt
+pyqode.qt:
+pyqode.qt:
+pyqode.qt:
+pyqode.qt:
+pyqode.qt: