summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-09-20 17:24:29 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-09-24 07:05:14 +0700
commit35b540543703fedfcb0355bb72defaeb2192a263 (patch)
tree3f7707adf5ae825d60a9a7c3e4a0b3aff5f9012d /python
parentd88d3ba7c8367bf2478a91f744f7c5a4ea96d8f1 (diff)
downloadslackbuilds-35b540543703fedfcb0355bb72defaeb2192a263.tar.gz
slackbuilds-35b540543703fedfcb0355bb72defaeb2192a263.tar.xz
python/xtermcolor: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python')
-rw-r--r--python/xtermcolor/xtermcolor.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/python/xtermcolor/xtermcolor.SlackBuild b/python/xtermcolor/xtermcolor.SlackBuild
index c4cde462fc..7638c377c0 100644
--- a/python/xtermcolor/xtermcolor.SlackBuild
+++ b/python/xtermcolor/xtermcolor.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for xtermcolor
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG