summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-06-18 16:06:20 +0300
committer Robby Workman <rworkman@slackbuilds.org>2016-06-18 19:16:53 -0500
commit3879f1eb8422212ac3e35b64c5a542363ffb6d50 (patch)
tree65f2b28c0fc7dfadfabe2c4f33600a1bbc895aaf /python
parente33b3a300e3b9da336d7a7055b6d22d4fe326d8e (diff)
downloadslackbuilds-3879f1eb8422212ac3e35b64c5a542363ffb6d50.tar.gz
slackbuilds-3879f1eb8422212ac3e35b64c5a542363ffb6d50.tar.xz
python/pycodestyle: Added (Python style guide checker).
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python')
-rw-r--r--python/pycodestyle/README2
-rw-r--r--python/pycodestyle/pycodestyle.SlackBuild89
-rw-r--r--python/pycodestyle/pycodestyle.info10
-rw-r--r--python/pycodestyle/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/python/pycodestyle/README b/python/pycodestyle/README
new file mode 100644
index 0000000000..878812eec3
--- /dev/null
+++ b/python/pycodestyle/README
@@ -0,0 +1,2 @@
+pycodestyle is a tool to check your Python code against some of the
+style conventions in PEP 8.
diff --git a/python/pycodestyle/pycodestyle.SlackBuild b/python/pycodestyle/pycodestyle.SlackBuild
new file mode 100644
index 0000000000..17d374742a
--- /dev/null
+++ b/python/pycodestyle/pycodestyle.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for pycodestyle
+
+# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pycodestyle
+VERSION=${VERSION:-2.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+# Fix permissions for docs and python egg-info folder
+chmod 0755 -R docs $PRGNAM.egg-info
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst CHANGES.txt docs/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pycodestyle/pycodestyle.info b/python/pycodestyle/pycodestyle.info
new file mode 100644
index 0000000000..983fcfaf29
--- /dev/null
+++ b/python/pycodestyle/pycodestyle.info
@@ -0,0 +1,10 @@
+PRGNAM="pycodestyle"
+VERSION="2.0.0"
+HOMEPAGE="https://pycodestyle.readthedocs.io/en/latest/"
+DOWNLOAD="https://pypi.python.org/packages/db/b1/9f798e745a4602ab40bf6a9174e1409dcdde6928cf800d3aab96a65b1bbf/pycodestyle-2.0.0.tar.gz"
+MD5SUM="733291d308def897c0c48c7840b7f6bc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/pycodestyle/slack-desc b/python/pycodestyle/slack-desc
new file mode 100644
index 0000000000..fa608e743a
--- /dev/null
+++ b/python/pycodestyle/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pycodestyle: pycodestyle (Python style guide checker)
+pycodestyle:
+pycodestyle: pycodestyle is a tool to check your Python code against some of the
+pycodestyle: style conventions in PEP 8.
+pycodestyle:
+pycodestyle: Homepage: https://pycodestyle.readthedocs.io/en/latest/
+pycodestyle:
+pycodestyle:
+pycodestyle:
+pycodestyle:
+pycodestyle: