summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-08-19 16:02:48 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-08-20 07:49:48 +0700
commit4713f95e77f920cb7c85ed787f222884756ac941 (patch)
tree981dea92078dfe8f4493fc5ccc74c7d99bedcabb /python
parent38d1a6b2bdd705c5271c29b54a2bc1fbb5de8a75 (diff)
downloadslackbuilds-4713f95e77f920cb7c85ed787f222884756ac941.tar.gz
slackbuilds-4713f95e77f920cb7c85ed787f222884756ac941.tar.xz
python/gunicorn: Added (WSGI HTTP Server for UNIX).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/gunicorn/README5
-rw-r--r--python/gunicorn/gunicorn.SlackBuild85
-rw-r--r--python/gunicorn/gunicorn.info10
-rw-r--r--python/gunicorn/slack-desc18
4 files changed, 118 insertions, 0 deletions
diff --git a/python/gunicorn/README b/python/gunicorn/README
new file mode 100644
index 0000000000..df43680025
--- /dev/null
+++ b/python/gunicorn/README
@@ -0,0 +1,5 @@
+Gunicorn 'Green Unicorn' is a Python WSGI HTTP Server for UNIX.
+It's a pre-fork worker model ported from Ruby's Unicorn project.
+The Gunicorn server is broadly compatible with various web
+frameworks, simply implemented, light on server resource usage,
+and fairly speedy.
diff --git a/python/gunicorn/gunicorn.SlackBuild b/python/gunicorn/gunicorn.SlackBuild
new file mode 100644
index 0000000000..d1d00528cc
--- /dev/null
+++ b/python/gunicorn/gunicorn.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for gunicorn
+
+# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=gunicorn
+VERSION=${VERSION:-19.6.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.rst NOTICE THANKS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/gunicorn/gunicorn.info b/python/gunicorn/gunicorn.info
new file mode 100644
index 0000000000..39133fc563
--- /dev/null
+++ b/python/gunicorn/gunicorn.info
@@ -0,0 +1,10 @@
+PRGNAM="gunicorn"
+VERSION="19.6.0"
+HOMEPAGE="http://gunicorn.org/"
+DOWNLOAD="https://pypi.python.org/packages/84/ce/7ea5396efad1cef682bbc4068e72a0276341d9d9d0f501da609fab9fcb80/gunicorn-19.6.0.tar.gz"
+MD5SUM="338e5e8a83ea0f0625f768dba4597530"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/gunicorn/slack-desc b/python/gunicorn/slack-desc
new file mode 100644
index 0000000000..a887bc0d2c
--- /dev/null
+++ b/python/gunicorn/slack-desc
@@ -0,0 +1,18 @@
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gunicorn: gunicorn (WSGI HTTP Server for UNIX)
+gunicorn:
+gunicorn: Gunicorn `Green Unicorn` is a Python WSGI HTTP Server for UNIX.
+gunicorn: It`s a pre-fork worker model ported from Ruby`s Unicorn project.
+gunicorn: The Gunicorn server is broadly compatible with various web
+gunicorn: frameworks, simply implemented, light on server resource usage,
+gunicorn: and fairly speedy.
+gunicorn:
+gunicorn: Homepage: http://gunicorn.org/
+gunicorn:
+gunicorn: