summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-10-06 13:10:18 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-08 08:07:20 +0700
commit5c9af8aa5243915e47267b5da97b66b9738b3e3a (patch)
tree570c86a21333b3cec81d9694fae1ce2cf3c8ac38 /python
parentd828c230c327c4c76704cb61e2d52d96fd81df83 (diff)
downloadslackbuilds-5c9af8aa5243915e47267b5da97b66b9738b3e3a.tar.gz
slackbuilds-5c9af8aa5243915e47267b5da97b66b9738b3e3a.tar.xz
python/pySmartDL: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python')
-rw-r--r--python/pySmartDL/pySmartDL.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/python/pySmartDL/pySmartDL.SlackBuild b/python/pySmartDL/pySmartDL.SlackBuild
index a506c444b5..9be9b13457 100644
--- a/python/pySmartDL/pySmartDL.SlackBuild
+++ b/python/pySmartDL/pySmartDL.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pySmartDL
-# Copyright 2014 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -65,9 +65,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG