summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@liwjatan.at>2017-01-26 22:24:57 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-28 07:38:09 +0700
commit6aa6e1a86b594dcd906206ab63100861cbe6147a (patch)
treeee5aac182f266bb4c87b65d1918fb33065939468 /python
parent48ae42730e1dc9f1359562358a8d58c8183c8871 (diff)
downloadslackbuilds-6aa6e1a86b594dcd906206ab63100861cbe6147a.tar.gz
slackbuilds-6aa6e1a86b594dcd906206ab63100861cbe6147a.tar.xz
python/python-gammu: Added (Python bindings for gammu).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-gammu/README2
-rw-r--r--python/python-gammu/python-gammu.SlackBuild72
-rw-r--r--python/python-gammu/python-gammu.info10
-rw-r--r--python/python-gammu/slack-desc19
4 files changed, 103 insertions, 0 deletions
diff --git a/python/python-gammu/README b/python/python-gammu/README
new file mode 100644
index 0000000000..364524f37e
--- /dev/null
+++ b/python/python-gammu/README
@@ -0,0 +1,2 @@
+Python bindings which allow you to use (most) of Gammu's functionality
+from Python language.
diff --git a/python/python-gammu/python-gammu.SlackBuild b/python/python-gammu/python-gammu.SlackBuild
new file mode 100644
index 0000000000..1769b64c0f
--- /dev/null
+++ b/python/python-gammu/python-gammu.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for python-gammu
+
+# Copyright 2017 Heinz Wiesinger, Amsterdam, The Netherlands
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-gammu
+VERSION=${VERSION:-2.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING NEWS.rst PKG-INFO README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-gammu/python-gammu.info b/python/python-gammu/python-gammu.info
new file mode 100644
index 0000000000..7eca61f90e
--- /dev/null
+++ b/python/python-gammu/python-gammu.info
@@ -0,0 +1,10 @@
+PRGNAM="python-gammu"
+VERSION="2.7"
+HOMEPAGE="https://wammu.eu/python-gammu/"
+DOWNLOAD="https://dl.cihar.com/python-gammu/python-gammu-2.7.tar.bz2"
+MD5SUM="f579882f1cb9a8c136fabaf0b7d3ad0a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="gammu"
+MAINTAINER="Heinz Wiesinger"
+EMAIL="pprkut@liwjatan.at"
diff --git a/python/python-gammu/slack-desc b/python/python-gammu/slack-desc
new file mode 100644
index 0000000000..7ceb7b0cbf
--- /dev/null
+++ b/python/python-gammu/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-gammu: python-gammu (Python bindings for gammu)
+python-gammu:
+python-gammu: Python bindings which allow you to use (most) of Gammu's functionality
+python-gammu: from Python language.
+python-gammu:
+python-gammu: Homepage: https://wammu.eu/python-gammu/
+python-gammu:
+python-gammu:
+python-gammu:
+python-gammu:
+python-gammu: