summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Barry J. Grundy <bgrundy [AT] linuxleo.com>2016-08-26 21:52:58 +0100
committer David Spencer <idlemoor@slackbuilds.org>2016-08-28 00:22:59 +0100
commit6b2c5aeca7e3ed8d6bb0120c7c27014e9b44c2d0 (patch)
tree4ac186b8d8076613c1b3e987d59aa2cb1a140d1c /python
parent0e2713d563b89d19ba31c4dd346395132c3a7e38 (diff)
downloadslackbuilds-6b2c5aeca7e3ed8d6bb0120c7c27014e9b44c2d0.tar.gz
slackbuilds-6b2c5aeca7e3ed8d6bb0120c7c27014e9b44c2d0.tar.xz
python/XlsxWriter: Added (write Excel 2007+ XLSX files).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/XlsxWriter/README21
-rw-r--r--python/XlsxWriter/XlsxWriter.SlackBuild86
-rw-r--r--python/XlsxWriter/XlsxWriter.info10
-rw-r--r--python/XlsxWriter/slack-desc19
4 files changed, 136 insertions, 0 deletions
diff --git a/python/XlsxWriter/README b/python/XlsxWriter/README
new file mode 100644
index 0000000000..4f578fd540
--- /dev/null
+++ b/python/XlsxWriter/README
@@ -0,0 +1,21 @@
+XlsxWriter - A Python module for creating Excel XLSX files
+
+XlsxWriter can be used to write text, numbers, formulas and hyperlinks to
+multiple worksheets and it supports features such as formatting and many more,
+including:
+
+ 100% compatible Excel XLSX files.
+ Full formatting.
+ Merged cells.
+ Defined names.
+ Charts.
+ Autofilters.
+ Data validation and drop down lists.
+ Conditional formatting.
+ Worksheet PNG/JPEG images.
+ Rich multi-format strings.
+ Cell comments.
+ Integration with Pandas.
+ Textboxes.
+ Memory optimization mode for writing large files.
+
diff --git a/python/XlsxWriter/XlsxWriter.SlackBuild b/python/XlsxWriter/XlsxWriter.SlackBuild
new file mode 100644
index 0000000000..67f93e7203
--- /dev/null
+++ b/python/XlsxWriter/XlsxWriter.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for XlsxWriter
+# Copyright 2016 Barry Grundy <bgrundy[at]linuxleo.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# New submission August 2016, Barry J. Grundy.
+
+PRGNAM=XlsxWriter
+VERSION=${VERSION:-0.9.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst LICENSE.txt Changes $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/XlsxWriter/XlsxWriter.info b/python/XlsxWriter/XlsxWriter.info
new file mode 100644
index 0000000000..2fa8cd73ef
--- /dev/null
+++ b/python/XlsxWriter/XlsxWriter.info
@@ -0,0 +1,10 @@
+PRGNAM="XlsxWriter"
+VERSION="0.9.3"
+HOMEPAGE="https://github.com/jmcnamara/XlsxWriter"
+DOWNLOAD="https://pypi.python.org/packages/75/46/f1552b4a4d6faa6ec39dc2ddcb56e6b9a2865f07b9e126b2144d9090f056/XlsxWriter-0.9.3.tar.gz"
+MD5SUM="9035b1e37a579c554e703404ffcebdd4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Barry J. Grundy"
+EMAIL="bgrundy<at>linuxleo.com"
diff --git a/python/XlsxWriter/slack-desc b/python/XlsxWriter/slack-desc
new file mode 100644
index 0000000000..060403449a
--- /dev/null
+++ b/python/XlsxWriter/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+XlsxWriter: XlsxWriter (Python module for writing Excel 2007+ XLSX files)
+XlsxWriter:
+XlsxWriter: XlsxWriter is a Python module that can be used to write text,
+XlsxWriter: numbers, formulas and hyperlinks to multiple worksheets in an Excel
+XlsxWriter: 2007+ XLSX file.
+XlsxWriter:
+XlsxWriter: https://github.com/jmcnamara/XlsxWriter
+XlsxWriter:
+XlsxWriter:
+XlsxWriter:
+XlsxWriter: