summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-10-06 12:57:12 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-08 08:07:20 +0700
commit6fe97d5b294e8572190caee33377430acf7186e4 (patch)
tree1f54406967c6aa3aac29ca63e9fa4519d46f5006 /python
parentcd2f712642d342f4dd4359db88fd343c035ce93b (diff)
downloadslackbuilds-6fe97d5b294e8572190caee33377430acf7186e4.tar.gz
slackbuilds-6fe97d5b294e8572190caee33377430acf7186e4.tar.xz
python/tox: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python')
-rw-r--r--python/tox/tox.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/python/tox/tox.SlackBuild b/python/tox/tox.SlackBuild
index 9d158c1231..5b96fd3c3f 100644
--- a/python/tox/tox.SlackBuild
+++ b/python/tox/tox.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for tox
-# Copyright 2014-2015 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG