summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author David Spencer <baildon.research@googlemail.com>2017-01-30 07:31:46 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-02-03 04:33:07 +0700
commit7a3fc8656e26ad2ac23fb3957a51effb9b7442fe (patch)
tree6ddabef11c822a7af98dd77f61f67b60acf26c92 /python
parent05d0fdb5902dbe686b82c53b93be3f355dc5f6c9 (diff)
downloadslackbuilds-7a3fc8656e26ad2ac23fb3957a51effb9b7442fe.tar.gz
slackbuilds-7a3fc8656e26ad2ac23fb3957a51effb9b7442fe.tar.xz
python/python-txaio: Added (compatibility for Twisted/Trollius).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-txaio/README4
-rw-r--r--python/python-txaio/python-txaio.SlackBuild87
-rw-r--r--python/python-txaio/python-txaio.info10
-rw-r--r--python/python-txaio/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/python/python-txaio/README b/python/python-txaio/README
new file mode 100644
index 0000000000..61b2a59c8c
--- /dev/null
+++ b/python/python-txaio/README
@@ -0,0 +1,4 @@
+txaio is a helper library for writing code that runs unmodified on both
+Twisted and asyncio / Trollius. This is like six, but for wrapping
+over differences between Twisted and asyncio so one can write code that
+runs unmodified on both.
diff --git a/python/python-txaio/python-txaio.SlackBuild b/python/python-txaio/python-txaio.SlackBuild
new file mode 100644
index 0000000000..28478980f2
--- /dev/null
+++ b/python/python-txaio/python-txaio.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for python-txaio
+
+# Copyright 2016 David Spencer, Baildon, West Yorkshire, U.K.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-txaio
+VERSION=${VERSION:-2.6.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-txaio/python-txaio.info b/python/python-txaio/python-txaio.info
new file mode 100644
index 0000000000..a9a44e5d7e
--- /dev/null
+++ b/python/python-txaio/python-txaio.info
@@ -0,0 +1,10 @@
+PRGNAM="python-txaio"
+VERSION="2.6.0"
+HOMEPAGE="https://pypi.python.org/pypi/txaio"
+DOWNLOAD="https://pypi.python.org/packages/14/4b/a1673c39212f26271a0dd067cde6790114bb43340fec15edabe9f6a70078/txaio-2.6.0.tar.gz"
+MD5SUM="e4b57e0512d2f439200c6040da7fd1a0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="six python-twisted"
+MAINTAINER="David Spencer"
+EMAIL="baildon.research@googlemail.com"
diff --git a/python/python-txaio/slack-desc b/python/python-txaio/slack-desc
new file mode 100644
index 0000000000..ed67d967bd
--- /dev/null
+++ b/python/python-txaio/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-txaio: python-txaio (source code compatibility for Twisted/Trollius)
+python-txaio:
+python-txaio: txaio is a helper library for writing code that runs unmodified on
+python-txaio: both Twisted and asyncio / Trollius.
+python-txaio:
+python-txaio: https://pypi.python.org/pypi/txaio
+python-txaio:
+python-txaio:
+python-txaio:
+python-txaio:
+python-txaio: