summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-08-16 06:37:04 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-08-20 07:49:48 +0700
commit8404bc9f60373d083c5a489be0adac36cc2d4d59 (patch)
treee3883afe30080801c6408ae5595e184719b73dbc /python
parent1f240809568897f073e27205e1db78d37c621b08 (diff)
downloadslackbuilds-8404bc9f60373d083c5a489be0adac36cc2d4d59.tar.gz
slackbuilds-8404bc9f60373d083c5a489be0adac36cc2d4d59.tar.xz
python/python3-future: Added (Python 2/3 compatibility).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-future/README3
-rw-r--r--python/python3-future/doinst.sh3
-rw-r--r--python/python3-future/python3-future.SlackBuild87
-rw-r--r--python/python3-future/python3-future.info10
-rw-r--r--python/python3-future/slack-desc19
5 files changed, 122 insertions, 0 deletions
diff --git a/python/python3-future/README b/python/python3-future/README
new file mode 100644
index 0000000000..8eef8438bd
--- /dev/null
+++ b/python/python3-future/README
@@ -0,0 +1,3 @@
+python-future is the missing compatibility layer between Python 2 and
+Python 3. It allows you to use a single, clean Python 3.x-compatible
+codebase to support both Python 2 and Python 3 with minimal overhead.
diff --git a/python/python3-future/doinst.sh b/python/python3-future/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/python/python3-future/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/python/python3-future/python3-future.SlackBuild b/python/python3-future/python3-future.SlackBuild
new file mode 100644
index 0000000000..187d9c401e
--- /dev/null
+++ b/python/python3-future/python3-future.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for python3-future
+
+# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-future
+SRCNAM=$(echo $PRGNAM | cut -c9-14)
+VERSION=${VERSION:-0.15.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-future/python3-future.info b/python/python3-future/python3-future.info
new file mode 100644
index 0000000000..69f5e4a7bf
--- /dev/null
+++ b/python/python3-future/python3-future.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-future"
+VERSION="0.15.2"
+HOMEPAGE="https://github.com/PythonCharmers/python-future"
+DOWNLOAD="https://pypi.python.org/packages/source/f/future/future-0.15.2.tar.gz"
+MD5SUM="a68eb3c90b3b76714c5ceb8c09ea3a06"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python3-future/slack-desc b/python/python3-future/slack-desc
new file mode 100644
index 0000000000..15ddbe5f94
--- /dev/null
+++ b/python/python3-future/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-future: python3-future (Python 2/3 compatibility)
+python3-future:
+python3-future: python-future is the missing compatibility layer between Python 2 and
+python3-future: Python 3. It allows you to use a single, clean Python 3.x-compatible
+python3-future: codebase to support both Python 2 and Python 3 with minimal overhead.
+python3-future:
+python3-future: Homepage: https://github.com/PythonCharmers/python-future
+python3-future:
+python3-future:
+python3-future:
+python3-future: