summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-08-15 18:15:23 +0100
committer David Spencer <idlemoor@slackbuilds.org>2016-08-15 18:15:23 +0100
commit87d233365696a2c5fab87c6ff8b32b6a3daef434 (patch)
tree2042e3ee11cf0287fceb990ae50c7dcd5d4e8c2e /python
parentda49156b5ca5d2a64c7ee393a8d82c2f72b2959a (diff)
downloadslackbuilds-87d233365696a2c5fab87c6ff8b32b6a3daef434.tar.gz
slackbuilds-87d233365696a2c5fab87c6ff8b32b6a3daef434.tar.xz
python/githubpy: Added (A simple GitHub v3 API SDK for Python).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/githubpy/README2
-rw-r--r--python/githubpy/githubpy.SlackBuild85
-rw-r--r--python/githubpy/githubpy.info10
-rw-r--r--python/githubpy/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/python/githubpy/README b/python/githubpy/README
new file mode 100644
index 0000000000..69de7ced41
--- /dev/null
+++ b/python/githubpy/README
@@ -0,0 +1,2 @@
+githubpy is a simple Python SDK for GitHub's API v3.
+It's all contained in one easy-to-use file.
diff --git a/python/githubpy/githubpy.SlackBuild b/python/githubpy/githubpy.SlackBuild
new file mode 100644
index 0000000000..52978fa58e
--- /dev/null
+++ b/python/githubpy/githubpy.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for githubpy
+
+# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=githubpy
+VERSION=${VERSION:-1.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/githubpy/githubpy.info b/python/githubpy/githubpy.info
new file mode 100644
index 0000000000..90d57f915a
--- /dev/null
+++ b/python/githubpy/githubpy.info
@@ -0,0 +1,10 @@
+PRGNAM="githubpy"
+VERSION="1.1.0"
+HOMEPAGE="https://github.com/michaelliao/githubpy"
+DOWNLOAD="https://pypi.python.org/packages/37/bc/29026d1386cd02fc6adc10e4703ccb0def00a752a83c35cf853b91b30cb2/githubpy-1.1.0.tar.gz"
+MD5SUM="eefeba8a198b2f573351da134749ae74"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/githubpy/slack-desc b/python/githubpy/slack-desc
new file mode 100644
index 0000000000..c91cc8358d
--- /dev/null
+++ b/python/githubpy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+githubpy: githubpy (A simple GitHub v3 API SDK for Python)
+githubpy:
+githubpy: githubpy is a simple Python SDK for GitHub's API v3.
+githubpy: It's all contained in one easy-to-use file.
+githubpy:
+githubpy: Homepage: https://github.com/michaelliao/githubpy
+githubpy:
+githubpy:
+githubpy:
+githubpy:
+githubpy: