summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2017-01-24 21:44:47 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-28 07:38:02 +0700
commit88e26a9d850073317b213beda47e5da8b881ccb0 (patch)
tree77691ac87eae3371c909afcba1ed08265cd20e84 /python
parent866186bcf6266eef7dd5209abc4818a0399d8c7d (diff)
downloadslackbuilds-88e26a9d850073317b213beda47e5da8b881ccb0.tar.gz
slackbuilds-88e26a9d850073317b213beda47e5da8b881ccb0.tar.xz
python/entrypoints: Added (Discover & load entry points).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/entrypoints/README4
-rw-r--r--python/entrypoints/entrypoints.SlackBuild85
-rw-r--r--python/entrypoints/entrypoints.info10
-rw-r--r--python/entrypoints/setup.py13
-rw-r--r--python/entrypoints/slack-desc19
5 files changed, 131 insertions, 0 deletions
diff --git a/python/entrypoints/README b/python/entrypoints/README
new file mode 100644
index 0000000000..aa2e1c23f2
--- /dev/null
+++ b/python/entrypoints/README
@@ -0,0 +1,4 @@
+The entrypoints module contains functions to find and load entry points. Entry
+points are a way for Python packages to advertise objects with some common
+interface. The most common examples are console_scripts entry points, which
+define shell commands by identifying a Python function to run.
diff --git a/python/entrypoints/entrypoints.SlackBuild b/python/entrypoints/entrypoints.SlackBuild
new file mode 100644
index 0000000000..19e6e91cae
--- /dev/null
+++ b/python/entrypoints/entrypoints.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for entrypoints
+
+# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=entrypoints
+VERSION=${VERSION:-0.2.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cp $CWD/setup.py .
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/entrypoints/entrypoints.info b/python/entrypoints/entrypoints.info
new file mode 100644
index 0000000000..ccc6bb1733
--- /dev/null
+++ b/python/entrypoints/entrypoints.info
@@ -0,0 +1,10 @@
+PRGNAM="entrypoints"
+VERSION="0.2.2"
+HOMEPAGE="http://entrypoints.readthedocs.org/"
+DOWNLOAD="https://github.com/takluyver/entrypoints/archive/0.2.2/entrypoints-0.2.2.tar.gz"
+MD5SUM="7dae980f7c6affd777dc60a51c8d0b0b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/entrypoints/setup.py b/python/entrypoints/setup.py
new file mode 100644
index 0000000000..e278244224
--- /dev/null
+++ b/python/entrypoints/setup.py
@@ -0,0 +1,13 @@
+
+from setuptools import setup, find_packages
+
+setup(
+ name='entrypoints',
+ version='0.3',
+ description='Discover and load entry points from installed packages',
+ url='https://github.com/takluyver/entrypoints',
+ author='https://github.com/takluyver',
+ license='MIT',
+ long_description='The entrypoints module contains functions to find and load entry points, a way for Python packages to advertise objects.',
+ py_modules=['entrypoints']
+)
diff --git a/python/entrypoints/slack-desc b/python/entrypoints/slack-desc
new file mode 100644
index 0000000000..64cff5aa88
--- /dev/null
+++ b/python/entrypoints/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+entrypoints: entrypoints (Discover and load entry points from installed packages)
+entrypoints:
+entrypoints: The entrypoints module contains functions to find and load entry
+entrypoints: points, a way for Python packages to advertise objects.
+entrypoints:
+entrypoints:
+entrypoints:
+entrypoints:
+entrypoints:
+entrypoints:
+entrypoints: