summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Brenton Earl <brent@exitstatusone.com>2017-01-14 06:01:44 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-14 06:01:44 +0700
commitabb7ef7b412229767a3f20b5556c832a004a5eba (patch)
tree5787f4617f1e80e0befab0c785d1fbd43ed53ec0 /python
parent2884e1333ebe6bfe4f4623a2cce74f887f0632a4 (diff)
downloadslackbuilds-abb7ef7b412229767a3f20b5556c832a004a5eba.tar.gz
slackbuilds-abb7ef7b412229767a3f20b5556c832a004a5eba.tar.xz
python/passlib: Add python3 support.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/passlib/passlib.SlackBuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/python/passlib/passlib.SlackBuild b/python/passlib/passlib.SlackBuild
index 635a64f4bc..54b24ce5a7 100644
--- a/python/passlib/passlib.SlackBuild
+++ b/python/passlib/passlib.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for passlib
-# Copyright 2015-2016 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2015-2017 Brenton Earl <brent@exitstatusone.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true